[mythtv-users] Schedules direct question

Michael T. Dean mtdean at thirdcontact.com
Sat Apr 11 20:52:36 UTC 2009

On 04/11/2009 04:37 PM, Mike McMullin wrote:
>   I'm working on setting up mythtv on openSuSE11.1.  I have a registered
> account (last 48 hours) with schedules direct and have put the user name
> and password into the mythtvsetup app.  I keep getting the following
> error(s) running "mythfilldatabase":
> Mike at P-733-Lin:~> mythfilldatabase
> 2009-04-11 16:34:56.548 Updating source #1 () with grabber
> schedulesdirect1
> 2009-04-11 16:34:56.549 No channels are configured to use grabber.

Looks like video source #1 is not configured.  It should a) have a name 
and b) have the grabber specified as Schedules Direct, and c) the 
appropriate Schedules Direct lineup selected.

> 2009-04-11 16:34:56.555 Grabbing listing data
> --2009-04-11 16:34:56--
> http://webservices.schedulesdirect.tmsdatadirect.com/schedulesdirect/tvlistings/xtvdService
> Resolving webservices.schedulesdirect.tmsdatadirect.com...
> Connecting to webservices.schedulesdirect.tmsdatadirect.com|
>|:80... connected.
> HTTP request sent, awaiting response... 401 Unauthorized
> Reusing existing connection to
> webservices.schedulesdirect.tmsdatadirect.com:80.
> HTTP request sent, awaiting response... 401 Unauthorized
> Authorization failed.

You should get one "Unauthorized" response followed by your client 
sending the username/password and then get a "Success" response.  So, it 
looks like your video source also needs d) a username/password specified.

>   Am I actually getting anything,


See, also, 
http://www.gossamer-threads.com/lists/mythtv/users/264034#264034 .  You 
may want to do the Video Sources portion of what's recommended by that 
post to clean up your current broken config before fixing it.


More information about the mythtv-users mailing list