[mythtv-users] "Unable to connect to mythbackend, is it running?" and other error messages

Kevin Kuphal kkuphal at gmail.com
Tue Oct 21 13:48:45 UTC 2008


On Mon, Oct 20, 2008 at 7:41 PM, Greg Hermsen <g.hermy15 at gmail.com> wrote:

> On Mon, Oct 20, 2008 at 5:02 PM, Michael T. Dean <mtdean at thirdcontact.com>wrote:
>
>> On 10/20/2008 09:42 AM, Kevin Kuphal wrote:
>> > Looks to me like your database crashed.  You should really investigate
>> > why the DB would suddenly disappear like this
>>
>> OOM killer, perhaps?
>>
>> Mike
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>>
>
> I have 1.5 GB of memory.  Would that make OOM killer unlikely?
>
> About an hour ago, I tried looking at the recorded program's list.  The
> system froze for about 1.5 minutes then I got a message that it "Unable to
> connect to mythbackend, is it running?"  I currently have only one machine,
> a combined BE/FE.
>
> I looked again at the *mythbackend.log* file.  There seemed to be more
> error messages there.
>
> ******************************
> ** Section with errors ****
> *****************************
> 8-10-20 18:29:29.719 [mpeg2video @ 0xb73a2a88]invalid cbp at 36 4
> 2008-10-20 18:29:29.722 [mpeg2video @ 0xb73a2a88]invalid cbp at 23 11
> 2008-10-20 18:29:29.723 [mpeg2video @ 0xb73a2a88]invalid cbp at 12 12
> 2008-10-20 18:29:29.728 [mpeg2video @ 0xb73a2a88]invalid mb type in P Frame
> at 14 14
> 2008-10-20 18:29:29.729 [mpeg2video @ 0xb73a2a88]ac-tex damaged at 4 15
> 2008-10-20 18:29:29.730 [mpeg2video @ 0xb73a2a88]ac-tex damaged at 4 15
> 2008-10-20 18:29:29.731 [mpeg2video @ 0xb73a2a88]ac-tex damaged at 30 17
> 2008-10-20 18:29:29.732 [mpeg2video @ 0xb73a2a88]ac-tex damaged at 22 18
> 2008-10-20 18:29:29.733 [mpeg2video @ 0xb73a2a88]ac-tex damaged at 9 20
> 2008-10-20 18:29:29.734 [mpeg2video @ 0xb73a2a88]slice mismatch
> 2008-10-20 18:29:29.735 [mpeg2video @ 0xb73a2a88]invalid cbp at 39 21
> 2008-10-20 18:29:29.736 [mpeg2video @ 0xb73a2a88]ac-tex damaged at 21 25
> 2008-10-20 18:29:29.737 [mpeg2video @ 0xb73a2a88]invalid cbp at 2 24
> 2008-10-20 18:29:29.738 [mpeg2video @ 0xb73a2a88]ac-tex damaged at 14 25
> 2008-10-20 18:29:29.739 [mpeg2video @ 0xb73a2a88]ac-tex damaged at 7 26
> 2008-10-20 18:29:29.748 [mpeg2video @ 0xb73a2a88]ac-tex damaged at 1 27
> 2008-10-20 18:29:29.749 [mpeg2video @ 0xb73a2a88]ac-tex damaged at 15 29
> 2008-10-20 18:29:29.828 [mpeg2video @ 0xb73a2a88]slice mismatch
> 2008-10-20 18:29:29.832 [mpeg2video @ 0xb73a2a88]slice mismatch
> Segmentation fault
>

In this case, your backend segfaulted.  In order to diagnose this, you can
do one of two things:

1.  Update to the latest  -fixes code to see if this has been addressed.
2.  Compile the -fixes branch with debug symbols and follow the instructions
on the mythtv.org website documentation for generating a backtrace so that
the developers can see what may be causing the crash

This is not the same issue you had before.

But, the fact that you have your database crashing and mythtv crashing leads
me to wonder if you may have a bad stick of memory causing both programs to
behave badly.

Kevin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20081021/693bc0b8/attachment.htm 


More information about the mythtv-users mailing list