[mythtv-users] backend thinks there is a frontend watching livetv

Matt Emmott memmott at gmail.com
Thu May 15 13:46:10 UTC 2008

On Thu, May 15, 2008 at 9:35 AM, Ronald Frazier <ron at ronfrazier.net> wrote:

> Late last week I opened up mythweb to look at the list of upcoming
> recordings and noticed something odd. There were 2 shows listed (1
> from the day before and one from 5 days before) that were showing as
> currently recording. I had seen this once before a while back, but
> didn't know what to make of it. This time I started poking around, and
> noticed that on the backend status page, it said tuner 1 was was
> watching LiveTV. That's nice, except that one of the frontends was in
> the main menu, and the other was powered off. I looked at the backend
> logs and it had been recording live tv for several days. Starting
> LiveTV on the frontend just made it grab another tuner...the mystery
> LiveTV instance kept running. I restarted the backend and the problem
> went away.
> Yesterday, my wife noticed that a program from last week didn't
> record. I looked at the recording history and it says the program was
> aborted. The thing is, neither of us had aborted any recordings. The
> show occurred during the period of time that mysterious frontend was
> watching live tv. I'm not sure if it's coincidence or related.
> I have a few questions:
> 1) Has anyone else experienced this?
> 2) Any idea how this could happen, that the backend thinks there is
> still a frontend running?
> 3) When the backend goes to record a program, but the tuner is busy,
> it sends a request to the frontend to take over the tuner. What
> happens if the frontend never responds (I don't mean the user not
> responding...I know that is handled, but what if the mythfrontend
> process itself never responded)? What action will the backend take?
> --
> Ron

Do you have any other frontends or is this your only Myth machine?  I've had
trouble getting XBMC to view my shows via the native myth:// setup - XBMC
will crash out after trying to view live TV but my BE thinks the XBMC boxes
are still connected and watching live tv. I have to restart the backend to
clear it out. Not sure if there's a more elegant way to fix it.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080515/4b4157a2/attachment.htm 

More information about the mythtv-users mailing list