[mythtv-users] mythvideos file problem on 0.21

James Pifer jep at obrien-pifer.com
Sat Jun 28 14:50:18 UTC 2008

On Sat, 2008-06-28 at 09:57 -0400, Michael T. Dean wrote:
> On 06/28/2008 09:41 AM, James Pifer wrote:
> > On Fri, 2008-06-27 at 22:09 -0600, Matt Nelson wrote:
> >   
> >> You prob need to run the "Video Manager" at least once.  Yes I know
> >> that you have it set to get "Newly scanned
> >> videos available by default" but I just worked with the same time of
> >> thing tonight, and I believe that I had to run the manager in order
> >> for it to have an initial data set to work off of...
> > Also a correction. The setting causing me the problem is "Video List
> > browses files". Makes me think it's a permissions issue,
> Yep.  Most likely.
> >  but the files
> > are there and readable over NFS. 
> By the user running mythfrontend?

Yes. My frontend machine (using mythdora 5) auto logs in as mythtv. It
mounts /mythtv to my backend's /mythtv using sudo. Then myth FE runs. 

As the mythtv user I can completely browse /mythtv and see all the
videos. I can even browse to an avi file and play it with vlc. I also
chown all the files to be owned mythtv. 

That being said, the UID for mythtv on my backend is 501. On my frontend
it's 500. I've tried changing mythtv user on my FE to 501 using usermod
and groupmod, and using find to change existing files, but that
completely hosed up gnome. 


More information about the mythtv-users mailing list