[mythtv-users] Volume/Mute not working with Intel integrated audio on Ubuntu

Michael T. Dean mtdean at thirdcontact.com
Mon Jun 23 15:55:57 UTC 2008

On 06/23/2008 10:36 AM, Johnny Russ wrote:
>> Just a couple points to note:
>>    1) internal volume control does not work with passthrough (and
>> cannot work with passthrough without softvol hacks or similar).
>>    2) if you're outputting multi-channel audio or "non-standard"
>> outputs in ALSA (Line, Headphone, any surround channel, etc.--basically
>> anything but PCM or Master), changing the master volume control will
>> have no effect with most ALSA drivers (and changing PCM volume control
>> will also, as expected, have no effect).
>> Both are sound driver/sound system "features" and have nothing to do
>> with Myth.
> I know my way around Linux pretty good but I haven't really messed with any
> of the audio stuff, so this is new territory for me. I don't know what
> passthrough is. I gather that has something to do with passing audio from
> the line-in jack to the output? I am not doing anything special. I am just
> playing back SD mpeg from a PVR-150. The sound volume controls work fine
> outside of Myth. Also I am using Intel integrated audio on my BE/FE fine. I
> assume there is some setting that I need to adjust to let Myth know how to
> control the volume on my system. Any help would be greatly appreciated.

If you're doing SDTV in the US (guess based on your e-mail domain name), 
you don't have AC-3 or DTS audio in your recordings, so passthrough 
doesn't apply.

What do you have set for Audio Output Device and Mixer Device and Mixer 
Controls in the Myth settings?


More information about the mythtv-users mailing list