[mythtv-users] Volume/Mute not working with Intel integrated audio on Ubuntu

Michael T. Dean mtdean at thirdcontact.com
Mon Jun 23 02:07:21 UTC 2008

On 06/22/2008 09:49 PM, Johnny Russ wrote:
> I added a new frontend. It is running Mythbuntu 8.04 on an old Dell 
> with Intel integrated audio. My audio works fine and I can adjust the 
> volume using the mixer within Ubuntu, but the volume controls and mute 
> within MythTV have no effect. The OSD comes up and shows the volume 
> going up and down or mute on and mute off, but the actual volume is 
> unaffected. I have seen other having similar issues in the Ubuntu 
> forums. Some had success by changing the audio settings under the 
> general settings in the frontend. I have tried changing between 
> /dev/mixer and Alsa and changing between PCM and Master, but I haven't 
> been able to get it working. Does anybody know what is going on or 
> have any ideas how to get these controls functioning again?

Just a couple points to note:

    1) internal volume control does not work with passthrough (and 
cannot work with passthrough without softvol hacks or similar).
    2) if you're outputting multi-channel audio or "non-standard" 
outputs in ALSA (Line, Headphone, any surround channel, etc.--basically 
anything but PCM or Master), changing the master volume control will 
have no effect with most ALSA drivers (and changing PCM volume control 
will also, as expected, have no effect).

Both are sound driver/sound system "features" and have nothing to do 
with Myth.

Don't know if those apply, but just in case.


More information about the mythtv-users mailing list