[mythtv-users] Mapping multimedia keys: "pressed key not recognized"

OCG Technical Support support at ocg.ca
Fri Jun 20 22:42:00 UTC 2008

Ok, here are the details:


Keyboard: Logitech DiNovo Mini (little wireless one)

Distro: Fedora 8


"showkey -k" can detect all of the multimedia keys, and I can even remap
then using xmodmap (eg to F11, F12) but Myth will STILL not accept the keys
("pressed key not recognized").


Should I need to use another app like xbindkeys?  Shouldn't Myth recognize
these keys since Linux does?





From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Brad DerManouelian
Sent: June 19, 2008 9:21 PM
To: Myth TV Users List
Subject: Re: [mythtv-users] Mapping multimedia keys: "pressed key not


On Jun 19, 2008, at 6:04 PM, OCG Technical Support wrote:

I've tried a few approaches to making the multimedia keys on my kbd play
nice with myth, but all have lead to dead ends.


I decided to take the simple approach, and use the myth setup menu for
keyboard mappings.  Now, I have myth (0.20) waiting for a key with "Press a
key", but when I press the PLAY button on my keyboard, myth says "pressed
key not recognized".


How do I get myth to recognize the multimedia keys?


You first needs to get linux to recognize the multimedia keys. Then myth
will magically start to recognize them.


It's hard to tell what you've tried to get this to work, but I'll assume you
tried something like this:

I also don't know what linux distribution you're using or what keyboard
you've got, so that makes it harder to help.


While you're at it, you should upgrade to 0.21-fixes. It has nothing to do
with multimedia keyboards, but all the cool kids are doing it.




-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080620/609ac2a0/attachment.htm 

More information about the mythtv-users mailing list