[mythtv-users] Help! Can't change channels after upgrade

peter at vanderwal.us peter at vanderwal.us
Tue Jun 10 23:11:54 UTC 2008

Some more data.

While watching live TV, I hit "e" to edit the channel data.  All fields
come up "Loading..."
Is it possible that the backend isn't reading the database for some reason?

I also noticed the following in the mythbackend.log file:
"Unable to rad configuration file mysql.txt"
not sure which one this refers to, the one in /usr/share/mythdora is
readable and just has the basic configuration in it.
the one in /home/mythtv/.mythtv is also readable and has the same

> Just upgraded from Mythdora 4 to Mythdora 5. Everything was working fine
> in M4 so I'm pretty sure it's not a hardware problem.
> I can't get Myth to change channels. I can open a terminal and use
> directv.pl to change channels no problem, but myth errors out.
> It acts like it's changing, the display freezes and then resumes, but it
> doesn't.  It defaults to Ch 4 and thinks it's still on 4 after trying to
> change channels (Ch4 is first channel)
> I have a Directv STB, using two USB to Serial converters with a null-modem
> connector.  Worked fine with M4
> I've tried chmod 777 on directv.pl, /dev/ttyUSB0, /dev/video and I've
> tried chown mythtv:mythtv on the same. still no go.
> I even set the external turner to /bin/true and it still acts the same way
> (errors out and thinks it's still on ch 4)
> I've deleted and reinstalled the video source twice, reloaded the channels
> twice. I've even deleted the capture card, source, etc and reinstalled.
> still no joy.
> tv_grab_na_dtv seems to be working fine and mythdatabasefill --manual
> grabs the right channels and sets up the database. The channels show up in
> the channel editor.
> The channels all show up in the OSD but it won't go to the new channel
> when I select it.
> Checked the logs and the backend error is:
> TVRec(2): HW Tuner 2->2
> Channel(/dev/video) Error: GetCurrentChannelNum(244): Failed to find
> Channel
> Channel(/dev/video)::TuneTo(244): Error, failed to find channel
> TVRec(2) Error: Failed to set channel 58
> Finished recording:  channel 4294967295
> TVRec(2) Error: GetProgramRingBufferForLiveTV()
>               Program Info is invalid.
> Possibly a clue: I have Input Connections set to default to channel 244. I
> also have the OSD set to start at channel 244. However when I open the OSD
> it's always on channel 4 (first channel) and if I use the remote to go up
> a channel it always starts by trying to change to channel 6 (second
> channel).
> Help!! I've been banging my head against the wall for three days now and I
> getting nowhere.
> System is a Asus M2NPV-VM mobo in an Antec Fusion case with VFD, Hauppauge
> 350 and remote. I'm using the component video output.
> I followed the tips about removing the Nividia drivers and installing
> Kmod-nivida so that's working. I also did the changes to get imon and
> lirc_i2c working so the remote works. Still have to fix SPDIF output.
> Sorry if this is a little disjointed, I'm so tired I'm seeing cross-eyed.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list