[mythtv-users] Strange, non-deletable entry in database

Bob Sully rcs at malibyte.net
Thu Jun 5 22:12:39 UTC 2008

Marshall Crocker wrote:
> I ran into the same problem after viewing live tv when my guide data was
> incomplete.  I fixed it by deleting the record in the recorded table where
> the title was null (empty string).  I don't know if there were any records
> linked to this entry but it had a primary key of something like 4294967295
> which I assume is invalid anyway. Deleting this record removed it from
> the watch recordings list.
> On 4/25/08, Bob Sully <rcs at malibyte.net> wrote:
>> Hi -
>> I have an index entry in my database that I can't get rid of.  It
>> occurred
>> the other night when I was watching live TV, when one of the tuners
>> couldn't seem to get a lock on a channel.  A "2 minute", 126MB file was
>> generated with the index entry _NO_TITLE_.  It did not expire, so I
>> tried
>> to delete it manually - the data file on disk went away but the index
>> entry didn't and trying to delete it both from mythfrontend and from
>> mythweb did not work.  Not only is it still in the list of recordings
>> (on
>> my main Mythbox, a BE/FE) but there's an annoying pause while the
>> frontend
>> looks for the data file that it's supposed to point to.
>> Stranger still - if I fire up mythfrontend on my FE-only machine
>> upstairs,
>> the entry isn't there.
>> Running optimize_mythdb.pl did not fix it.

Yeah, I finally got rid of it by going into the database manually and
searching for a blank space in the "title" field of the recordings table,
then deleting that record.


Bob Sully - Simi Valley, California, USA

More information about the mythtv-users mailing list