[mythtv-users] Myth thinks capture cards are gone due to invalid SQL query

Tom Dexter digitalaudiorock at gmail.com
Sun Jun 1 18:50:45 UTC 2008

On Sun, Jun 1, 2008 at 2:25 PM, Doug Meredith
<doug.meredith at skyridge.com> wrote:
>> 0.20.2 had parentid and childcardid, so rather than someone upgrading
>> you past 0.20.2, it sounds like you're now running some downgraded
>> version.
> Curious.  Does a script even exist to do a schema downgrade?
>> More likely, though, is your DB is corrupt.
>> Run optimize_mythdb.pl (from contrib). After that, if it still doesn't
>> work, try the Delete all capture cards thing (
>> http://www.gossamer-threads.com/lists/mythtv/users/264034#264034 ).
> I wondered about that, but can't find any evidence of it.  I can query
> both tables just fine.  Having a column simply disappear seems like a
> very unlikely manifestation of database corruption.  Having two
> (presumably) related columns in two different tables disappear seems
> even less likely.
> I've run optimize_mythdb.pl and it runs without complaints.  I've
> deleted video sources and capture cards, but that doesn't seem to have
> solved the problem.  The two missing columns have not reappeared
> (assuming they were ever there) in the tables.  I can add the video
> sources back without problem.  When I add the capture cards back they do
> appear in the table, but they don't show up in mythtv-setup due to the
> query failure on parentid.
> Every time I start the backend or mythtv-setup I see a message that it
> is doing a schema upgrade.  I'm assuming this is just a check that is
> done at every startup, and doesn't really indicate that it's doing
> anything.  Can anyone confirm this?
> Is there a way I can check for further differences between my schema and
> what is expected for 0.20.2?  Is there a way to force it to upgrade the
> schema?
> Thanks for the help so far.  Anything further would be greatly
> appreciated as well.
> Doug
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Did you by any chance upgrade to mythtv 0.21 and then attempt to go
back to 0.20.2 with the same database or something?  That's almost
what it sounds like.

Do you have a storagegroup table?  If you're schema did in fact get
upgraded at some point you would.


More information about the mythtv-users mailing list