[mythtv-users] XvMC and skipping forward locks frontend

Brian Sanders brian.sanders at gmail.com
Thu Jul 10 13:54:00 UTC 2008

With XvMC my CPU runs at around 50-60% but it doesn't seem to be a processor
load problem.  So with a 2.4Ghz you couldn't play the video?  I thought with
over 2Ghz you could probably play it with out XvMC.  As my system has
shown... with XvMC correctly configured I don't see why that system couldn't
play it.  The NvAGP 1 option would mean you where using the nvidia agp
drivers as opposed to agpgart (I think that is what it is called).
Unfortunately I have tried everything I can think of to get AGP to work, and
I can only get XvMC to do anything with AGP turned off all together.  I even
flashed the bios on my motherboard hoping to get something going... no love.

Like I said... if mplayer didn't play, or if it played choppy I would
understand.  It just seems odd that I can play with mplayer using XvMC and
everything is great.  I can play with MythTV and XvMC... unless I hit a
botton to skip :(  Till I hit skip though... it flows right along.  I guess
I haven't watched it for more than about 2 minutes.  So I can't say it plays
flawlessly for hours.  Then again I have watched parts of this HD clip so
many times I don't think I could stand to watch it till the end!

On Thu, Jul 10, 2008 at 9:42 AM, Alen Edwards <allen.edwards at oldpaloalto.com>

> Brian Sanders wrote:
> > Hey everyone, been using Mythtv for a while now, and finally ran into a
> > spot where I might need some help from the list.  So as the subject
> > might suggest, I am working on getting XvMC working on my frontend to
> > make HD playback an option.  I have read over all the Nvidia/Wiki/google
> > material I can find, but I seem to be having a mythtv centered playback
> > problem.
> >
> > I can play files with mplayer using xvmc, and I can even play video
> > files from my videos directory if I tell mythtv to use mplayer.  When I
> > try and use "Internal" the playback does start seemingly smoothly, but
> > as soon as I try and skip forward or back, the entire system freezes
> > requiring a power cycle.  I am using this video file as a test before I
> > start trying to record HD programs and find out I can't play them.  I am
> > assuming that recorded programs need to use the internal player for
> > commercial skipping, plus I never saw an option to set what player is
> > used for recorded programs.
> >
> > So, I can play with xvmc if I launch mplayer from the terminal, OR if
> > mythtv is told to use mplayer.  Skipping around in the video is very
> > smooth and quick.  Since it plays with one application but not MythTV I
> > am hoping someone can help me out here.  This is an old machine (hence
> > the xvmc) so perhaps I will end up upgrading this machine and bypassing
> > the entire xvmc need... but honestly I keep fighting with this b/c I
> > believe it "should" work :)
> >
> >
> > Just incase this might help someone... here are some things I learned
> > about my setup while getting xvmc to even work at all.
> >
> > If AGP is enabled (kernel or nvidia) standard recordings still play, but
> > xvmc fails to do anything.  I have tried setting both "NvAGP" for "1"
> > and "2" to force the module I was testing at the time, nothing works.  I
> > now run with AGP disabled "NvAGP" "0", and xvmc works with mplayer and
> > tries to work with myth.  While trying to make this work I have
> > re-complied the nvidia drivers to adjust the AGP speed down from 4x to
> > 2x, and 1x.  I tested all three modes (4x,2x,1x) with both Nvidia and
> > kernel drivers with no better results using any combination.  I
> > confirmed that AGP setting where being detected by using "cat
> > /proc/drivers/nvidia/agp/status" which confirmed I was actually running
> > with the modules and speeds I was trying to test.  I now accept that no
> > AGP is the only way to get xvmc to run on my machine.
> >
> > Setup:
> > Pentium 4 1.7Ghz
> > Gentoo with latest kernel (upgraded this as well trying to get xvmc agp
> > to work)
> > Nvidia Geforce 6200
> >
> > My xorg.conf settings
> > Section "Device"
> >     Identifier     "Card0"
> >     Driver         "nvidia"
> >     VendorName     "nVidia Corporation"
> >     BoardName      "NV20 [GeForce 6200]"
> >     Option         "UseEvents" "true"
> >     Option         "XvmcUsesTextures" "false"
> >     Option         "NvAGP" "0"
> > EndSection
> >
> > Section "Extensions"
> >         Option "Composit" "Disabled"
> > EndSection
> >
> >
> > Thanks for any suggestions
> > Brian
> >
> > --
> > "Faithless is he, who says 'farewell', when the path darkens
> > "you just keep on trying till you run out of cake"
> >
> >
> > ------------------------------------------------------------------------
> >
> > _______________________________________________
> > mythtv-users mailing list
> > mythtv-users at mythtv.org
> > http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> When I ran XvMC on my P4 2.4GHz (6200 video as well) I used Option
> "NVAGP" "1" with the other options you have and it almost worked.  I
> came to the conclusion that my computer was just too slow.  I could
> watch an hour of HDTV and the sound would skip every 10 minutes or so.
> Annoying to say the least.
> I would be surprised it it worked with your CPU.  I bought a new system
> and found that XvMC didn't even work that well on that so switched the
> config to CPU++ and it is much better.
> Something to consider.
> Allen
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

"Faithless is he, who says 'farewell', when the path darkens
"you just keep on trying till you run out of cake"
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080710/7899694b/attachment.htm 

More information about the mythtv-users mailing list