[mythtv-users] ffwd & skipping jumps all the way to the end of recordings

Jonno jonnojohnson at gmail.com
Tue Jul 1 23:19:29 UTC 2008

Ok I've tried:
optimize_mythdb.pl - no errors
mysqlcheck --auto-repair -A -u mythtv -pmysqlpass - no errors
mysqlcheck -r -u mythtv -pmysqlpass mythconverg - no errors

I'd like to run the myisamchk but I can't figure out how to run Ian's
I also found this article, http://wiki.linuxmce.org/index.php/Setting_up_MythTV
which also suggests myisamchk by doing:
 cd /var/lib/mysql/mythconverg
 /etc/init.d/mythtv-backend stop
 /etc/init.d/mysql stop
 myisamchk *.MYI -r
but here I run into the problem that I can't cd into that directory as
I'm denied permission.
Here are the permissions for that directory:
drwx------ 2 mysql mysql    12288 2008-07-01 18:01 mythconverg
Should I modify them or am I on the wrong track?

On Tue, Jul 1, 2008 at 9:10 AM, Jonno <jonnojohnson at gmail.com> wrote:
> Ok I got optimize_mythdb.pl to work by adding execute permissions to it for the user and adding the ./ to the command
> It seemed to run ok. No obvious error messages.
> Then I tried to run mythcommflag on a recently recorded tv show and it seems to hang at "Finding Logo". Any idea why that is? If it's related to the logo for the tv station I don't generally have those (I use OTA broadcast digital tv and schedules direct).
> Also assuming I manage to get past the Finding Logo issue, is there a way to run mythcommflag on an entire directory of recordings (since they all seem messed up).
> I also tried looking for errors in the tables by using this command:
> mysqlcheck -c -uroot -p mythconverg
> but I always get an access denied message. I have tried changing resetting the mysql password but nothing seems to help.
> Any pointers on any of this stuff would be great.
> Jonno.
> On Tue, Jul 1, 2008 at 8:25 AM, David Watkins <watkinshome at gmail.com> wrote:
>> > I tried to run the optimize_mythdb.pl script but I get "command not found"
>> > even though I can see the script in the
>> > /usr/share/doc/mythtv-backend/contrib directory.
>> > Is this likely a problem with the permissions setup?
>> more likely a problem with the path.
>> either type the full path or, if you're already in the directory
>> ./optimize_mythdb.pl
>> that's not to say you won't get a permission problem :-)
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list