[mythtv-users] Problem with suspend to ram (s3)

G L glafranceweb at yahoo.com
Wed Jan 23 05:42:54 UTC 2008


I originally posted about my problem on the Ubuntu forums (
 http://ubuntuforums.org/showthread.php?t=673729 ). Having received
 not a single reply, I decided to give it a shot here, since it's a very friendly place ( BTW thanks John for your help with my remote control problem, you're awesome :) ).  Also, I've been googling for 2 evenings now and I cannot find any clear solution to this.

Please tell me if this is too much off-topic for this list, I won't
 feel offended or anything. :)
I was going to try the linux-acpi mailing list first... but I got the
 impression that it was more of a "dev" mailing list.

First, here's what I'm using:

Mythbuntu 7.10 Gutsy 
Biostar TF7050-M2 motherboard (with latest BIOS) 
AMD Athlon 64 X2 4400+ Brisbane 
Seagate Barracuda 500GB SATA2

When I suspend (S3), it seems to work okay. Computer goes to sleep and
 I don't hear any fans or the hard drive, and the screen goes blank.

When I resume, it *seems* wake up okay, until, I think, it tries to
 wake up the hard drive. Then all I get on the screen are errors like

ata1 soft reset failed
ata1 COMRESET failed
device sda5 XFS metadata write error block <bunch of numbers>
Buffer I/O error on device sda1, logical block <some number>
Remounting filesystem read-onlyAll I see are error messages like above
 scrolling... it doesn't seem to stop until I poweroff the computer,
 wait a few seconds, then poweron and it boots normally.

Seems to me that the computer is unable to wake up the hard drive from
 its beauty sleep. :-/

I enabled/uncommented the following two lines in


...but the problem persists. 

Do I need to modify something else in the acpi-support file?

Then I tried to follow the instructions on this page (
 http://zechs.dyndns.org/wordpress/?p=234 ) to get s2both and s2disk to

When I tried Suspend, nothing seemed to happen at first. I was still
 seeing the desktop environment on the screen, the mouse cursor was still
 moving. I could still click on buttons and icons, however it would have
 no effect. No program would start.

So I rebooted.

What followed is one of the worst hard drive problem I've ever saw!  It
 said that /dev/sda1 has way too many errors and that it'll only mount
 read-only so that I can run fsck manually. Then it gave me a root shell

I ran fsck, there were many many inode and block errors about this and
 that. I was feeling pretty bummed out so I just answer 'y' when it
 would ask me if I wanted to fix the problem.

The computer then rebooted again, and everything seemed to run
 normally. I tried all different programs and things (to see if any important
 files had been damaged), but everything looks okay. (Phew?)

I still can't seem to get suspend to work though... which is a pain because I want to make the computer suspend to ram when I press the power button of my remote. :-|


More information about the mythtv-users mailing list