[mythtv-users] 1st tuner on Nova-t 500 can't tune

Henrik Beckman henrik.list at gmail.com
Tue Jan 22 07:37:31 UTC 2008

mt2060 I2C read failed
mt2060 I2C write failed

Is a known issue with the Nova-T 500, there is ongoing work on the issue and
there has been a few patches the last weeks.
Bad reception and EIT scanning can provoke the problem, but with the latest
firmware the problem seems to occur only with bad reception.
Hopefully the latest patches will have this solved once and for all, people
are still testing this.

IIRC only the write fail is fatal, though someone on this list had a retry
patch for this.

One workaround is to have a script that monitors and restarts the backend
when this happens, might have to do more, my memory is bad.

Look at the wiki and the linux-dvb mailinglist for more info.


On Jan 21, 2008 10:56 PM, M1ANH <m1anh at hotmail.com> wrote:

> RE: First tuner stops working, in Mythweb "0B" is displayed in the file
> size
> and no screen shot is avaliable.
> In the console (dmesg) I get a mix of:
> mt2060 I2C read failed
> mt2060 I2C write failed
> Oliver Maunder-3 wrote:
> >
> >
> > but it looks like it could be related to EIT scanning.
> > In the console I get lots of entries like:
> >
> > [735440.608000] mt2060 I2C read failed
> >
> > I was going to try disabling EIT and setting up XMLTV instead, but I
> think
> > I'll wait until Radio Times sort out their listings!
> >
> After reading this I changed my setting in the Mythbackend - Sources to
> "No
> Grabber"
> It has now been running for a week with no missed recording.
> So I changed it back to the EIT Data source, waited an hour, and "mt2060
> I2C
> read failed" was reported in the console.
> Currently I am manually updating the guide by turning on and off the EIT
> data in the sources to work around the problem.
> There must be a bug here some where? I was going to have a channel tidy
> up,
> It could be trying to tune in to a channel that has no or invalid data.
> Possibly an encrypted channel. I no very little about how this works, but
> you are on to something here. Thanks for the post.
> --
> View this message in context:
> http://www.nabble.com/1st-tuner-on-Nova-t-500-can%27t-tune-tp14515576s15552p14989799.html
> Sent from the mythtv-users mailing list archive at Nabble.com.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080122/6e3d60f2/attachment.htm 

More information about the mythtv-users mailing list