[mythtv-users] Viewing encrypted DVB-S channels

Jelte Veldstra jelte.veldstra at gmail.com
Tue Jan 15 07:51:44 UTC 2008

Since all works fine in Kaffeine the kernel support should be there for your
system. I have used my Canal Digitaal subscription reliably on a FC4 host
running a vanilla 2.6.19 kernel and MythTV 0.20.2 for about a year now. For
me to get it working proved to be a matter of getting that kernel. BTW the
DVB-S adapter in my host is a Twinhan 1030A.

There may be issues with the scanning capabilities in Myth. Another thing to
check is how you tell Myth the LNB is connected (straight to the DVB-S
adapter or is there a LNB switch in between). I have not used the scanning
capabilities of MythTV but used the dvb-apps tools to scan for channels. You
could try the same and select the three lines for Nederland 1 till 3 out of
this scan. Then in mythtv-setup drop the DVB-S adapter and all associated
inputs and channels. Then add the adapter again, set the LNB access up,
create new inputs and use the previously created channels scan with the
three Nederland 1-3 channels.

That should give you a working config with the three Nederland channels. If
that works reliably you can start importing the other Dutch channels as

Good luck! I have spent a lot of time on this as well, but now comparing it
with analog cable, it has been well worth the effort.



P.S. Another route to try is using a Phoenix interface for the Canal
Digitaal smartcard and sasc-ng as a softcam. Googling for NewCS and sasc-ng
should give you pointers on this setup.

On Jan 14, 2008 8:05 PM, Johan <johan.vanderkolk at dommel.be> wrote:

> On Mon, 2008-01-14 at 08:43 +0100, belcampo wrote:
> > Re: [mythtv-users] Viewing encrypted DVB-S channels To: Discussion about
> > mythtv <mythtv-users at mythtv.org> Message-ID:
> > <1200219388.13378.14.camel at phoenix> Content-Type: text/plain On Sat,
> > 2008-01-12 at 13:43 +0000, Stroller wrote:
> >  > > On 11 Jan 2008, at 19:36, Johan wrote:
> >  >> > > ... since all dutch
> >  >> > > satellite channels are encrypted, this is a major issue and I
> >  >> > > decided to
> >  >> > > get a CI interface an a CAM, to use with my official
> subscription
> >  >> > > smart
> >  >> > > card.
> >  >> > >
> >  >> > > To my surprise it does not work, I do not get to see the
> encrypted
> > DVB-S and CI-Interface and CAM should indeed work as you expected. It
> > works in Mythtv for several years for me in the Netherlands. And if it
> > works as you say with Kaffeine, it should also work with all other apps.
> > under linux.
> >
> > Belcampo
> >
> >
> I just installed vdr, just for the sake of testing and it also works.
> So this is not a linux dvb driver problem, but something in mythtv.
> Just wondering where the difference is. Which version of mythtv are you
> running in a working configuration ? I have already checked if the Pid
> (Service id under Mythtv) entry in the mythconverge date base is ok, and
> it looks like 2004 is the right number for RTL4.
> Johan
> > _______________________________________________
> > mythtv-users mailing list
> > mythtv-users at mythtv.org
> > http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080115/441ae616/attachment.htm 

More information about the mythtv-users mailing list