[mythtv-users] SVN - compile error - libavcodec

Mark markhsa at shaw.ca
Mon Dec 22 17:18:11 UTC 2008


Michael T. Dean wrote:
> On 12/22/2008 12:03 PM, Mark wrote:
>   
>> I ran into something similar on Fedora 10.  Just check this.  Do a 
>> "which gcc"
>> I found that a compile would fail because there was a package installed 
>> by default called "ccache" which put a gcc in your path before /usr/bin/gcc.
>>   
>>     
>
> That's (1 of 2 ways) how ccache is used.  By having a link called gcc 
> referring to the ccache binary (rather than gcc) in the PATH before the 
> directory containing gcc, ccache is used when gcc is called and--because 
> it was called using the name "gcc"--knows that it should "do gcc 
> stuff."  (The other way to use ccache is much more difficult/invasive, 
> so most everyone uses it as described.)
>
>   
>> Check that and let me know.  My compile failed in the same place due to 
>> this.
>>     
>
> Likely a:
>
> ccache -c
>
> (or, definitely, a ccache -C) would have fixed it, if ccache were, in 
> fact, the issue.  However, it's very likely that ccache was not to 
> blame, but something else--such as a not-cleaned-up source dir--was, and 
> not using ccache just worked around the issue.
>
> Mike
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>
>   

Perhaps.  All I know is that on two machines ( upgrade and fresh install 
) ccache caused problems on compile.  When I removed it, all worked just 
fine.

Mark


More information about the mythtv-users mailing list