[mythtv-users] [ATrpms-users] Confused: why did video performance DECREASE (up to 70%) after upgrading video card by 2 generations??? Please validate my analysis

Jeffrey J. Kosowsky mythtv-users at kosowsky.org
Mon Dec 8 15:21:47 UTC 2008

George Mari wrote at about 08:17:52 -0600 on Monday, December 8, 2008:
 > Jeffrey J. Kosowsky wrote:
 > > George Mari wrote at about 21:55:00 -0600 on Sunday, December 7, 2008:
 > >  > Jeffrey J. Kosowsky wrote:
 > [deleted]
 > >  > > In both cases it seems like the video lags the
 > >  > > sound with the sound pausing every few seconds to wait for the "slower
 > >  > > motion" video to catch up giving the sound a jerky appearance.
 > >  > > 
 > >  > > Also with the older card when viewing HD programs (but not SD
 > >  > > programs) I got a lot of "NVP: prebuffering pause" errors in addition
 > >  > > to the "WriteAudio: buffer underruns" that occur with each sound
 > >  > > pause. I assume this is consistent with the fact that CPU usage is
 > >  > > becoming a bottleneck on the 4600 for HD.
 > >  > > 
 > Hi Jeff.  Did you read through this page on the wiki?  Especially the 
 > section "Audio issues" that specifically mentions the error message you 
 > got - "WriteAudio: buffer underruns".
 > http://www.mythtv.org/wiki/index.php/Troubleshooting:Prebuffering_pause

Yes - I did. But unfortunately it didn't offer too many solutions for
audio setup ;)
 > Tell us about -
 > 1. Your distro
   	  Fedora 8 updated fully to kernel
	  mythtv-0.21-198 (from atrpms)

 > 2. Your desktop (KDE, Gnome, other)
   	  Gnome 2.2

 > 3. What sound system you're using (ALSA, PulseAudio, OSS)
	  (but I tried disabling Pulseaudio by removing the
   	  pulse-default.conf file and using just OSS but then the sound
	  became totally choppy (not clear then pausing) but completely

 > 4. Audio system config file (alsa.conf)
   	  I am using the stock one from Fedora 8 but I will attach below

 > 5. Your audio hardware (built-in motherboard audio, PCI card, make and 
 > model)
	  Integrated into my P4PE. The gnome desktop applet detects it as
			 Vendor: Intel
			 Model: Corporation 82801DB/DBL/DBM (ICH$/ICH$-L/ICH4-M)
			 		AC'97 Audio Controller
			 Module: snd-intel8x10
			 PCM device: Intel 82801DB-ICHR

	   		0 Intel Corporation 82801DB/DBL/DBM (ICH$/ICH$-L/ICH4-M)

 > 6. Audio driver version
   	  	Hmmm... I guess I am using the latest kernel alsa plus the
   	  	latest Fedora 8 pulseaudio version (0.9.8)

 > 7. Your audio settings in your mythfrontend setup
   	  	Here are the settings from the 'General' screen:
			Audio output device: ALSA:default [/dev/dsp]
				  Note ALSA:pulse seems to give the same result.
				  Using other settings from the pulldown list either
   	  			  gives me completely garbled sound or no sound at all
				Passthrough output device: Default
					Note using  'ALSA:Alsaiec958:{AES0 0x02}' gives
   	  				the same result
				Max AUdio Channels: Stereo
				Upmix: Passive
				-Enable AC3 to SPDIF passthrough
				-Enable DTS to SPDIF passthrough
				-Aggressive Soundcard Buffering
						(I tried both with and without)
				-Use internal volume controls

   	  	Here are the settings from the TV/Playback section:
 					+Enable realtime priority threads
						(I tried both with and without)
					+Extra audio buffering
						(I tried both with and without)
					+Warn on no audio output
					-Use video as timebase
						(I tried both with and without)
					+Clear Saved Position on playback
					+Alternate Clear Saved Position
					+Jump to Program OSD
					-Continue Playback When Embedded
					-Automatically mark a recording as watched
					-Always stream reocrdings from the backend
					+Enable OPenGL vertical sync for timing
						(I tried both with and without)
					-Enable picture controls					
 > 8. Anything else audio-related I haven't thought of. :-)

I guess what frustrates me is that after DAYS of trying, I'm still not
sure if this is an audio or video problem.

On the one hand, you might say it is an audio problem given that the
audio pauses are most obvious and the error messages on the surface
seem to be mostly audio-related "WriteAudio: buffer underruns".

On the other hand, a closer look shows that the video is playing back
slightly slow while the audio sounds perfectly normal until it
presumably gets too far ahead of the video and underruns the
buffer, which leads to a pause while the stream catches up. So, I'm
thinking that maybe it is more of a video problem.

But I can't figure out why the video is being slowed down even though
I seem to have enough CPU (40% or so free) and given that others seem
to have found the 6200 fast enough to play even 1080i.

Also, interestingly, I get the same problems even when watching
(digital) SD but NO problems when playing a live analog stream or
playing back even 1080i after transcoding to mpeg4. Also, the problem
occurs both when watching LiveTV and when watching previously recorded
(but non transcoded) streams.

Also, mplayer does not have this problem either when directly viewing
OTA broadcasts or even when viewing streams recorded by mythtv.

So, it seems to me that there is something wrong with how mplayer
(and/or my configuration of it) is playing back HD streams.

I have tried seemingly every imaginable combination of playback
configs, including:
	- With/without XvMC
	- With/without OpenGL
	- With/without interleaving
	- With different OSD rendering
	- With/without using video as timebase
	- With different nvidia drivers (96.xxx, 173.xxx, 177.xxx)
	- With different screen resolutions
All of the above have NO EFFECT on the actual audio/visual performance
other than to change CPU usage.

It really seems like either mplayer or I are missing one thing that is
bottlenecking the decoding of digital streams.

I was thinking first of returning the 6200 and buying a 7600gs board,
but given the above, it is not at all clear to me that the problem is
a video hardware one since the 6200 should be sufficient, particularly
at SD ;)

I really want to fix this...

More information about the mythtv-users mailing list