[mythtv-users] DVD drive won't eject

Matt skd5aner at gmail.com
Thu Sep 27 17:24:04 UTC 2007

On 9/27/07, Phil Bridges <gravityhammer at gmail.com> wrote:
> On 9/27/07, Matt <skd5aner at gmail.com> wrote:
> > I've noticed a problem that's started to occur over the past month of
> > two.  I'm running current SVN (as of this week), and over the past
> > couple of months I've noticed that I can no longer manually control my
> > DVD drive with the button on the front of it.
> >
> > When I try the "Eject Media" it will work a few times, but then it
> > will always come up with an error message saying "Unable to open or
> > close the empty drive LITE-ON DVDRW SHW-160P6S (/dev/scd0).  You may
> > have to use the eject button on the drive".  However, like I've said,
> > it's like myth locks the utilization of the physical eject button.  If
> > the frontend isn't running, it works just fine.  When I use the "eject
> > media" options, it'll turn on the LCD light on the drive, spin it up
> > for about a second, and then the message comes up.
> >
> > The only way I can ever resolve this is by rebooting the machine.  Any
> > ideas on how to fix this?  I think this is a myth problem because it
> > used to work with the physical button just fine.
> >
> Could it be a permissions issue for the drive?

Not sure... what should the permissions be?  The weird thing is that
it works a few times, but then quits working.  Also, like I said, once
mythfrontend is running the physical eject button does nothing.


More information about the mythtv-users mailing list