[mythtv-users] DirecTV STB USB port

Rob S zerogeek at gmail.com
Wed Sep 26 20:31:32 UTC 2007

So I (think) this problem is finally resolved.  Figured it might be helpful
for someone else down the line to post what I did to solve it.  Long story
short - the LNB on our dish was bad and needed to be replaced.

Somehow this translates into the box(es) eventually ignoring all messages
sent to through the USB port.  Sometime after this strange problem surfaced
occasionally only half of the channels would work (they would show satellite
signal not found).  This was due to only half of the two transponders
getting a signal.

Bottom line - if your direcTV box suddenly stops changing channels and
*will* once you do a hard reboot of the box then you direcTV signal may be
degraded somewhat due to cabling or a bad LNB.


On 9/12/07, David George <david at thegeorges.us> wrote:
> On 09/11/2007 11:29 PM, Rob S wrote:
> > Well....I now know that it's not a widespread sort of thing and by
> > looking at the firmware on my boxes I discovered that they haven't
> > been updated since June or so.  I upgraded myth last week (for the
> > schedules direct switch) and apparently in doing so I somehow created
> > this bizarre behavior.  I have no idea how upgrading myth would cause
> > the directv.pl script to suddenly not work...but I guess weirder
> > things have happened. Anyway, thanks for your help guys...guess I'll
> > revert things and hope it doesn't break again.
> One of my D12-300 just started doing the same thing.  I had updated to
> latest trunk SVN as of last week.  What I found was the directv3.pl
> script I was using would work fine from the command line, but the
> receiver would just get the last digit when executing channel changes
> from inside Myth (e.g. in LiveTV).  I added verbose to my channel change
> command line so I could see what it was doing and it started working
> reliably so I haven't looked into it further.  This is on my
> frontend/slave backend.  The same script with the same receivers work
> fine on my master backend without the verbose option.
> HTH,
> --
> David
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070926/ff2523dd/attachment.htm 

More information about the mythtv-users mailing list