[mythtv-users] Mythcommflag is off by one

Austin Roberts mythtv at ausiv.com
Mon Sep 24 02:10:33 UTC 2007

I'm experiencing a rather strange error. For quite a while, I had one show
that MythTV was trying to commflag, but the file itself wasn't there so
MythTV was hanging up and not continuing through the job queue. So I told it
to start running two jobs at once. Then a couple months back I reinstalled
my OS (and subsequently MythTV). I was able to get the old episode to
disappear once and for all, so I set the job queue back to 1 job. Now I have
a new problem.

When I record a show, mythcommflag runs on  that show and reports 0 breaks
found. Then, it runs on whatever the second most recent show is, and finds
breaks. It goes something like this:

Record A
A has no commflag.
Record B
A has a commflag
B has no commflag
Record C
B has a commflag
C has no commflag

And so on. Whatever show I have most recently recorded does not have a

If I run mythcommflag from mythtv on the most recent show, it reports 0
breaks found very quickly. If I run it from the CLI, it's able to flag the

Has anyone experienced this, or can anyone suggest a way to fix it? It's not
a huge deal, because its' fairly rare that I actually want to watch the most
recently recorded show, but I find it rather strange.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070923/daaeff23/attachment.htm 

More information about the mythtv-users mailing list