[mythtv-users] Running mythfilldatabase

Patrick Wagstrom patrick at wagstrom.net
Tue Sep 18 23:30:33 UTC 2007

Michael T. Dean wrote:
> On 09/17/2007 04:49 PM, Patrick Wagstrom wrote:
>> Cottrell, Eric wrote:
>>>> OK, I may be blind, but...
>>>> This morning when I checked the schedules, I found that 
>>>> mythtv didnt know anything about what was on the air.
>>>> So I ran mythfilldatabase by hand, and we were back in business.
>>>> Now running this automagically USED to be an option somewhere 
>>>> in myth-setup. I ran thru all the options there and never 
>>>> found it (so never found if it were 
>>>> set
>>>> on or off...)
>>>> Am I blind? Has it moved? Is it on by default?
>>> On 0.20.2 I found it in the frontend menus under setup->general.  It is
>>> several settings pages in.
>>> I would be interested if it works because I upgraded from 0.16 and
>>> mythfilldatabase does not automagically run anymore.  Maybe they ran out
>>> of magic after 0.18 8).
>> I experienced a similar phenomena with my MythTV box.  The machine has 
>> been graciously updated a number of times from 0.8 up to 0.20.2 now. 
>> Before the most recent upgrade to 0.20.2 I still ran the grabber through 
>> a cron job, like in the bad old days.  I figured that the change to 
>> schedules direct was incentive to activate the automatically fetch 
>> listings option, however, it never actually fetches the listings, and it 
>> leaves not trace in my logs of even trying.
>> So, I'm back to running it with a cron job.
>> Sounds like mythfilldatabase not automatically running may be a 
>> moderately common issue.
> Perhaps you two, too, are suffering from the issue that I described in
> Eric's thread (if so--if the below solutioin fixes the issue for any/all
> of you), please let me know as I can probably make a case for getting a
> "fix" into 0.20-fixes).  I'll re-post my answer here since it hasn't yet
> made it into the archives:
> It sounds like you may be using the "Run mythfilldatabase at time
> suggested by grabber" but the time that was last suggested (i.e. by a
> "manual" execution of mythfilldatabase) is not in the window during
> which mythfilldatabase is allowed to run. To fix it, change the
> "mythfilldatabase Execution Start/End" times to 0 and 24, respectively.
> In 0.20.2 (and 0.20-fixes), the window is "moved" to a period of a
> couple of hours around the suggested time by the backend when the
> backend runs mythfilldatabase. So, if mythfilldatabase is run manually,
> no one is updating the window and it may or may not line up with the
> last-updated window. In SVN trunk (and, in 0.21, when it's released),
> the window isn't changed, rather it's ignored. See
> http://www.gossamer-threads.com/lists/mythtv/commits/263447#263447 .

I checked and saw that I did indeed have a narrow window specified to 
run mythfilldatabase, so I opened it up to the whole day, 0-24.  Waited 
  a day, no mythfilldatabase was run.  According to the system, it was 
supposed to run at 16:52pm.  Oh well, it's not that major of a deal, 
cron does the job just as well, but I'm not being as nice.


More information about the mythtv-users mailing list