[mythtv-users] No SD Update and SD Episode Numbers do notmatchprevious recordings

Cottrell, Eric ecottrell at doble.com
Tue Sep 18 14:25:48 UTC 2007

> -----Original Message-----
> From: mythtv-users-bounces at mythtv.org 
> [mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Michael T. Dean
> Sent: Monday, September 17, 2007 11:16 PM
> To: Discussion about mythtv
> Subject: Re: [mythtv-users] No SD Update and SD Episode 
> Numbers do notmatchprevious recordings
> On 09/17/2007 12:12 PM, Cottrell, Eric wrote:
> > I have "Automatically run mythfilldatabase" checked.  I tried 
> > unchecking and checking again.  I tried using the full path to 
> > mythfilldatabase and the default.  I tried it with the use 
> suggested 
> > time both checked and unchecked.
> >
> > Running mythfilldatabase from the command line works.  It 
> never runs 
> > from MythTV.  No log entries.  The other two housekeeping tasks are 
> > running as the dates in the housekeeping table are updating.
> >
> > I am running SuSE 10.2 with the latest MythTV packages 
> (0.20.2) from 
> > Packman mirror.  After install I restored my old database.  
> I am going 
> > to grab the latest SVN source and compile it myself.  I understand 
> > there are some bugs in the suggested time portion that were fixed.  
> > Maybe it is causing other problems.
> OK.  It sounds like you may be using the "Run 
> mythfilldatabase at time suggested by grabber" but the time 
> that was last suggested (i.e. by a "manual" execution of 
> mythfilldatabase) is not in the window during which 
> mythfilldatabase is allowed to run.  To fix it, change the 
> "mythfilldatabase Execution Start/End" times to 0 and 24, 
> respectively.
> In 0.20.2 (and 0.20-fixes), the window is "moved" to a period 
> of a couple of hours around the suggested time by the backend 
> when the backend runs mythfilldatabase.  So, if 
> mythfilldatabase is run manually, no one is updating the 
> window and it may or may not line up with the last-updated 
> window.  In SVN trunk (and, in 0.21, when it's released), the 
> window isn't changed, rather it's ignored.  See 
> http://www.gossamer-threads.com/lists/mythtv/commits/263447#263447 .
> Mike


I did notice the min and max times shifting around when the "time
suggested by grabber" option was checked.  My box was not turned off
during update times.  I unchecked the "time suggested by grabber" option
a couple of days ago and it still does nothing.  Do I have to wait two
or three days after a manual run to see if the autorun works?

I am going to check the 0.20-fixes branch and see if there are any
updates after the packman packager did the mythtv packages.  It seems a
few other people are having the problem as well.  Maybe a recent change
broke something.  I would hate to have to go back to compiling mythtv

73 Eric

73 Eric

More information about the mythtv-users mailing list