[mythtv-users] Software Update always results in X not starting

Gabe Rubin gaberubin at gmail.com
Mon Sep 17 08:27:06 UTC 2007

On 9/17/07, MythTV <MythTV at assuredsolutions.com> wrote:
> I have tried using other xorg.conf files that I know have worked in
> the past.  I have tried removing and installing the NVidia drivers:
> yum remove nvidia-graphics9746-libs nvidia-graphics-devices nvidia-
> graphics-helpers
> yum -y install nvidia-graphics9746-libs nvidia-graphics-devices
> nvidia-graphics-helpers
> Only if I reboot the computer and select the older Kernel, then X
> will start and everything is fine.
> So my latest updates were run an 9/16/2007.  I now have Fedora Core
> ( as one boot Kernel and Fedora Core
> (2.6.20-1.2944.fc6) as my second boot Kernel.  X will not start with
> the newest kernel,  Instead the Xorg.0.log ends with this:
> (II) Setting vga for screen 0.

sounds like you need to install the kernel module; assuming you have
set up KVER to be = 'uname -r' (and if you haven't, see Jarod's guide
for how to do so):
yum install nvidia-graphics9746-kmdl-$KVER

in the future, whenever you update your kernel, you will need to
update the kernel modules for the nvidia driver, alsa, ivtv, lirc, and
potentially other drivers using the same method outlined above.

More information about the mythtv-users mailing list