[mythtv-users] MythFrontend and MythSetup crash X (FC7, nvidia)

Jerome Yuzyk jerome at supernet.ab.ca
Fri Sep 14 05:30:18 UTC 2007

On Thursday 13 September 2007 23:12, Jerome Yuzyk wrote:
> OK I am almost getting my old FC5 setup upgraded to FC7, I had to fuss with
> nvidia drivers to update them so that X would run and now that X actually
> runs, trying to open mythfrontend or mythtvsetup gives me this:
> Backtrace:
> 0: X(xf86SigHandler+0x81) [0x80ceb41]
> 1: [0x12d420]
> 2:
> /usr/lib/xorg/modules/extensions//libGLcore.so(xmesa_check_and_update_buffe
>r_si ze+0x32) [0x872272]
> 3: /usr/lib/xorg/modules/extensions//libGLcore.so(XMesaResizeBuffers+0x29)
> [0x874a
> 09]
> 4: /usr/lib/xorg/modules/extensions//libGLcore.so [0x8abf70]
> 5: /usr/lib/xorg/modules/extensions//libglx.so [0x4ca3ba]
> 6: X(compPositionWindow+0x59) [0x81021a9]
> 7: X(ReparentWindow+0x1ac) [0x80774dc]
> 8: X(ProcReparentWindow+0xd5) [0x8088d95]
> 9: X [0x814efd1]
> 10: X(Dispatch+0x1aa) [0x808936a]
> 11: X(main+0x495) [0x80710a5]
> 12: /lib/libc.so.6(__libc_start_main+0xe0) [0x213f70]
> 13: X(FontFileCompleteXLFD+0x1e1) [0x8070391]
> Earlier in my Xorg.log there is this:
> (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
> (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
> (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module. 
> If (EE) NVIDIA(0):     you continue to encounter problems, Please try (EE)
> NVIDIA(0):     reinstalling the NVIDIA driver.
> I do have a  Load  "glx"  line in my xorg.conf.
> According to X my card is a  NVIDIA GPU GeForce 6100 (C51)
> If I revert out to the nv driver Mythfrontend starts but the colours are
> all weird and blocky and I can't see any text.

I did a full poweroff and reboot and now I can get to mythfrontend and 
mythtvsetup but after the "pre-scaling theme image" nothing appears. The 
keyboard is recognized, in that I can Esc and get the "do you want to quit?" 

More information about the mythtv-users mailing list