[mythtv-users] NFS issue

Harry Devine lifter89 at comcast.net
Wed Sep 12 00:16:31 UTC 2007

-------------- Original message -------------- 
From: "R. G. Newbury" <newbury at mandamus.org> 

> Harry Devine wrote: 
> > I have a FC6 box as my main PC aside from my MythTV box (which is also FC6). 
> I setup and NFS share on my main box to share my MP3 collection. I would like 
> to mount to that directory from my MythTV box to copy over all of the MP3s to 
> use in MythMusic. However, whenever I try to mount the directory, I get the 
> following error message: 
> > 
> > "mount: mount to NFS server '' failed: System Error: No route to 
> host." 
> > 
> > My IPTables firewall on both boxes have the following lines in them: 
> > "-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 2049 -j 
> > 
> > If I stop the iptables service on my main PC, I can mount it fine, so I know 
> its a firewall issue. I know that 2049 is the NFS port (via /etc/services), so 
> why wouldn't NFS be working in my case? I'd like to have it work, then 
> automount it via /etc/fstab. 
> > 
> Since all of the answers seemed to deal only with top/bottom posting... 
> go here: http://nfs.sourceforge.net/nfs-howto/ 
> and jump to section 7, Troubleshooting 
> It explains the error messages and what to do to fix them. 
> You probably have a firewall problem. Fedora has nice little program 
> called 'lokkit' which allows you to fiddle with the firewall and 
> iptables. You need to open the correct ports. 
> You may have other errors too, so check out that page. IIRC you need 
> port 22 open. 
> Geoff 
> -- 
> R. Geoffrey Newbury 
> Barrister and Solicitor 
> Suite 106, 150 Lakeshore Road West 
> Mississauga, Ontario, L5H 3R2 
> o905-271-9600 f905-271-1638 
> newbury at mandamus.org 
> Helping with the HTTP issue 
> _______________________________________________ 
> mythtv-users mailing list 
> mythtv-users at mythtv.org 
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users 

Thanks for the link.  I checked it out, but didn't really help much.  All it really said in my case was that I was a victim of an overzealous firewall.  I recently took a RedHat Firewall class for my job, so I'm going thru those materials to see what the problem is, but nothing as of yet.  I still get the same error.
I tried adding a rule on the UDP port 2049 (for NFS), similar to the TCP equivalent, but I still get the same error.  I tail'd /var/log/messages and /var/log/secure on my NFS server, but no messages came up when my Myth box tried to NFS-mount to the share.
Any other ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070912/f2ba64de/attachment.htm 

More information about the mythtv-users mailing list