[mythtv-users] svn mythweather having trouble probing scripts

Jack Perveiler perveilerj at gmail.com
Sat Sep 8 04:13:34 UTC 2007

I recently updated to r14365 and gave the new mythweather a try.  Almost
none of the scripts are validated when probed, however.  They all die with
this in the frontend log:

2007-09-07 23:57:53.281 Error Running Script
2007-09-07 23:57:53.281 Can't locate NDFDParser.pm in @INC (@INC contains:
/etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8
/usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl /usr/local/lib/perl/5.8.7
/usr/local/share/perl/5.8.7) at
/usr/local/share/mythtv/mythweather/scripts/ndfd18.pl line 3.

I instrumented weatherSource.cpp and verified that the script absolute path
and the workingDirectory are correct for the script, but I still get these

If I manually cd to /usr/local/share/mythtv/mythweather/scripts and run the
script everything goes swimmingly.

Interestingly enough, if I do this:

/usr/bin/perl -e "print qq(@INC)" then I get this as my include path:

/etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8
/usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl /usr/local/lib/perl/5.8.7
/usr/local/share/perl/5.8.7 .

It's the same as the path in the error message, with one big exception: it
includes the trailing "." directory whereas the error message does not.

If i modify a given script to add "-I." then things work again.


what's the deal with the perl include path being different?  The path is
different whether or not I execute it myself or it's launched with
QProcess::start().  Is this just a red herring?  I confess I don't know much
about how perl (v5.8.8, in my case) forms it's include path.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070908/f9c37153/attachment.htm 

More information about the mythtv-users mailing list