[mythtv-users] Mythfrontend (and X11) dying...

CHRIS KOTTING ckotting at wideopenwest.com
Thu Sep 6 17:49:18 UTC 2007

On Thu, 06 Sep 2007 10:59:41 -0600, clemens wrote
> Im running Fedora6, updated to the present date, and MythTV, updated 
> to 4Sep.
> Ive found that over the last few weeks, if I leave 'Live TV' runing 
> overnight, when I come in in the morning, the screen is BLACK.

Okay, I have to ask.  Why would you leave Live TV running overnight?  I 
figure you have a reason.  I just have no clue what it would be, and my 
curiosity is getting to me.

> Trying to revive it ( <ESC>  (Mythtv), or <CTL> <ALT> <BKSP> (X11), 
> nothing happens.
> If I go to another machine and ssh into mythtv-fe, the Frontend 
> machine, I find that neither mythfrontend, nor X11 is running.  I 
> can restart things at that point by doing a 'startx' and then 
> restarting 'mythfrontend'.
> My question is, do others see this behaviour?
> I dont remember it happening in the past (more than a month ago...)

I've never seen it happen, but then again, I've never tried to do what 
you're doing.  My guess, right off the top of my head, is that something in 
X is going kersplat and taking the frontend with it.

Methinks a peek at the X log files would be useful (look 
in /var/log/Xorg.n.log, where "n" can be any number from 0 to whatever).  
Use the timestamp on the file to figure out which one to look at first.

I'm guessing that your frontend and backend are on different machines (since 
you are ssh-ing into your frontend specifically).  Does the backend keep 
recording when the frontend goes away?

More information about the mythtv-users mailing list