[mythtv-users] Fedora 8, Intel G33 video, opengl vertical sync issues

Graeme Wilford gwilford at gmail.com
Mon Nov 19 23:51:34 UTC 2007

On 19/11/2007, George Nassas <gnassas at mac.com> wrote:
> On 10-Nov-07, at 10:30 PM, Jason Surprise wrote:
> > latest intel 2.1.1 xorg driver which I couldn't figure out how to
> > build
> > ...
> > is enabled. glxgears is working.  However, I am now unable to set 'Use
> > OpenGL for vertical sync for timing' in mythtv.  I get video that is
> > unwatchable and the following error message from myth:
> > ...
> > 2007-11-10 19:25:23.068 OpenGLVideoSync::Start(): A/V Sync reported
> > error: Bad Context
> Sorry, I didn't see your post until just now.
> The problem is the 2.1.1 driver only supports GL sync for 3D
> operations. Luckily it's easy to restore support for 2D sync as well.
> Details are here:
> http://lists.freedesktop.org/archives/xorg/2007-June/025304.html
> Basically go to src/i830_dri.c and make I830DRITransitionTo2d look a
> lot like I830DRITransitionTo3d. Myth now reports it's using DRI sync
> instead of OpenGL but whatever, the tearing is gone, the picture is
> awesome and life is good.
> Later in the thread the developers signal they're going to straighten
> this out at some point so you won't have to patch the driver forever.
> - George

For reference, the same problem is present in
xorg-x11-drv-ati-6.7.195-3.fc8and also
v6.7.196 of the ATI driver. Downloading the later and replacing the FALSEs
with TRUEs in RADEONDRITransitionTo2d() provides a similar work-around.
However, despite getting DRI vblank to work, I'm now seeing refresh jitter
with bobdeint that I didn't get with the Xorg 6.9 drivers using identical
MythTV frontend playback config...

This needs more testing when I've had some sleep.

Me at google |
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20071119/88212421/attachment.htm 

More information about the mythtv-users mailing list