[mythtv-users] Fedora 8, Intel G33 video, opengl vertical sync issues

Graeme Wilford gwilford at gmail.com
Sun Nov 18 23:13:36 UTC 2007

On 11/11/2007, Jason Surprise <thesurprises1 at comcast.net> wrote:
> Hi I recently upgraded my fedora 7 system to 8, mainly to get at the
> latest intel 2.1.1 xorg driver which I couldn't figure out how to build
> on the f7 system.  The upgrade went smoothly.  All the video bits seem
> to be working properly.  DRI is enabled, glxinfo shows direct rendering
> is enabled. glxgears is working.  However, I am now unable to set 'Use
> OpenGL for vertical sync for timing' in mythtv.  I get video that is
> unwatchable and the following error message from myth:
> 2007-11-10 19:25:17.051 Using realtime priority.
> [mpeg2video @ 0x1060960]Warning MVs not available
> 2007-11-10 19:25:19.150 NVP: Timed out waiting for free video buffers.
> 2007-11-10 19:25:20.314 TV: Attempting to change from
> WatchingPreRecorded to None
> 2007-11-10 19:25:23.068 OpenGLVideoSync::Start(): A/V Sync reported
> error: Bad Context
> 2007-11-10 19:25:23.069 Video timing method: SGI OpenGL
> 2007-11-10 19:25:26.072 OpenGLVideoSync::Start(): A/V Sync reported
> error: Bad Context
> If I disable this setting, video playback is normal.

Also seeing this with an old onboard Radeon 9100 in Fedora 8. It's been
working using GL sync for years on a heavily-hacked FC3 setup. Did the
OpenGLVideoSync API change in the latest Fedora X server?

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Fedora Core 7 Red Hat, Inc.
Current Operating System: Linux xxx #1 SMP Thu Nov 8
21:41:26 EST 2007 i686
Build Date: 17 October 2007
Build ID: xorg-x11-server

This is with mythtv 0.20.2 using Axel's RPMs.

Me at google
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20071118/99751708/attachment.htm 

More information about the mythtv-users mailing list