[mythtv-users] dd_v_ tables missing from mythconverg

David Shay david at shay.net
Tue Nov 13 03:05:19 UTC 2007

On 11/12/07, Michael T. Dean <mtdean at thirdcontact.com> wrote:
> On 11/12/2007 09:14 AM, R. G. Newbury wrote:
> > William Munson wrote:
> >
> >> R. G. Newbury wrote:
> >>
> >>> I think I have borked by mythconverg database and do not have an old
> >>> enough backup to reconstruct the prior state.
> >>>
> >>> SVN 14830 segfaulted at every attempt to play LiveTV or from the
> >>> library. I stepped back to 14794. But I think the error may have
> >>> predated that as I have listings for only 8 days. This is most likely
> >>> the result of a schema advance and revert...Operator error!
> >>>
> >>> DBSchemaVer is 1201. Mythfilldatabase reports that is cannot do
> inserts
> >>> to various "dd_v_xxx" tables. Those tables do not exist.
> >>>
> >>> So, how do I "re-update" and make it stick? As noted, 14830 segfaults
> badly.
> >> I have not tried this myself but you should be able to change
> >> DBSchemaVer in the settings table to a lower number and rerun
> >> mythtv-setup to re-upgrade your database. With a reasonably current SVN
> >> I have a version of 1201.
> >>
> >
> > I tried something like this...I changed DBSchemaVer to 1200 in
> > mysql...
> Generally not a good idea to mess with DBSchemaVer...  Always better to do
> > but I cannot now be sure that I didn't just restart mythbackend
> > and frontend....I cannot remember.
> > But whatever I did, changed DBSchemaVer to 1201 again, but DID NOT
> > create the missing tables....
> >
> > I will try it again, running mythtv-setup first.
> >
> > Anyone else have any good ideas? (I don't mind hearing *bad* ideas, but
> > I make no promises about using them!)
> the MythTV "Spring Cleaning" (TM):
> http://mythtv.org/docs/mythtv-HOWTO-23.html#ss23.7
> Mike
> ___

Can't dispute that.  Those tables aren't created via the db schema upgrade
processes, but rather these are "temporary tables" created/used by the data
direct class of processors (now schedules direct).  As long as you are using
a version of mysql 3.23 or later, it supports temporary tables correctly.
Prior to 3.23 I think it ignored the "temporary" table construct, although
the code is supposed to handle that situation as well, I think.

I would shut down the mythbackend and any filldatabase processes, login to
mysql and check to see if there are any dd_v* tables there.  If they exist,
you can delete them.  This should only be the case, though, if you are using
mysql prior to 3.23.  If they exist and you are using later than that,
something has gone terribly awry.

It they don't exist, then there is some other error in the filldatabase
process.  What is the exact error message that mythfilldatabase is giving?
Can you run it with more logging?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20071112/ef05a5ff/attachment.htm 

More information about the mythtv-users mailing list