[mythtv-users] Mythwelcome and ACPI wake up

fb517255 at skynet.be fb517255 at skynet.be
Thu Nov 8 17:28:44 UTC 2007


It's already a long time that I am trying to make a nice mythtv box.
Almost everything works correctly except the mythwelcome part. 

What's happening? When mythtv does a shutdown it writes
to /roc/acpi/alarm and my pc wakes up correctly on the desired time.In
the start-up of the user I have made mythwelcome start automatically.
The strange this is that I don't have the mythwelcome screen but only
the mythfrontend which blocks the pc to do a shutdown after the
recording. What's going wrong?

Can somebody point me in the right direction please.

command used for start-up (added in .gnomerc)
sleep 10 && mythfrontend -v all > /tmp/mythfrontend.log 2>&1&
(log to big to be attached but I don't see anything special i it.)

in the logfile mythbacked.log I found something like recordingstarting
in less as 15 min so auto start-up assumed.

mythwelcome settings:
nvram-wakeup command: sudo /usr/binMythWakeTime.sh
command to reboot: sudo shutdown -h -r -now
command to run to start the frontend: /usr/bin/mythfrontend

mythtv-setup settings
idle timeout: 300
max. wait time fro recording:5
Startup before rec:300
wakeup time format: yyyy-MM-dd hh:mm:ss
Set wakeuptime command: sudo /usr/binMythWakeTime.sh $time
server halt command: sudo mythshutdown --shutdown

The script /usr/binMythWakeTime.sh is a simple batch that writes its
arguments to /proc/acpi/alarm which seems to work as the pc wakes

All help appreciated,


More information about the mythtv-users mailing list