[mythtv-users] mythtv 18.1 -> 20.2 upgrade

Maaltan Naatlam maaltan at gmail.com
Thu Nov 8 00:58:05 UTC 2007

An update.  i think the issue that is causing the hard freezes is either
running out of disk space.   I had a similar issue with the ringbuffer in
18.1 when i set it too big.  It may also be trying to delete the same file
twice.  the only clue i have found is the following log

2007-11-07 02:12:43.228 Expiring Unknown from Wed Nov 7 01:30:00 2007, 1114
MBytes, free space is too low (have 3042 MBytes free , but want 3186 MBytes)
2007-11-07 02:12:43.306 autoexpire: Expiring Program: Expiring Unknown from
Wed Nov 7 01:30:00 2007, 1114 MBytes, free space is too low (have 3042
MBytes free , but want 3186 MBytes)

Is there any way use the ringbuffer method in 20.2?   i dont think the ext3
file system is fast enough on my system to delete files to keep the new live
tv approach happy.

Also, mythfilldatabase does not seem to populate today's data.  just 6-12+
hours to 14 days or so in the future.. therefore i never have data i can

On Nov 5, 2007 11:29 PM, Maaltan Naatlam <maaltan at gmail.com> wrote:

> I decided to upgrade my mythtv box this weekend so i could use the
> schedules direct service. Unfortunately things went wrong.
> First, my setup
> Hardware:
> dell dimension cx700e (?)
> Celeron 700mzh
> 500mb ram
> HD1: 20gb
> hd1a: 4gb / 76% full
> hd1b: 1.5gb <swap>
> hd1c: 3gb /livecache 0% full (no longer used in 20.2)
> hd1d: remainder /myth/mythtvburn 5% full
> hd2: 120gb
> hd2a: LVM logical volume 120gb /myth 96% full
> random hp dvd burner and floppy drive.
> PVR-350 (tvout used for X and video)
> PVR-150 MCE
> Software:
> OS: Debian sarge net install (2.4x kernel)
> IVTV driver: 0.4.1
> all prereqs regulation package installs except for QT... which is custom
> built. the built in install script did not put them in the right
> directories, so i had to do some creative symbolic linking to get it to work
> for the 18.1 build. I could not uninstall the package QT because for some
> reason apt wanted to take my kernel with it. i think the version is 3.3.6.
> it was the newest available 3x when 18.1 came out.
> Problem:
> My problem boils down to 4 main issues (in approximate order of
> importance.
> 1: Random HARD system freezes while watching video.
> When watching live tv, the system hard freezes before any logs can be
> written. its an instant and thorough freeze. everything from ping to video
> dies. Only recourse is a cold boot.
> I have tried clearing the mythtv settings and repairing/optimizing the db
> tables. I have also tried to trigger the freeze by consuming memory,
> consuming cpu, etc. It seems like it freezes slightly more when the CPU is
> busy but nothing definitive.
> I found the "delete slowly" box in the settings this morning. This does
> not appear to help.
> 2: Mythfilldatabase wiped out all program data last night (nov 5th ~5 am)
> I was debugging until about 8AM or so, it magically worked again. An issue
> at schedules direct maybe?
> 3: All themes are too long and buttons are always cut off the bottom.
> If i shrink the window size i get a black bar and buttons are cut off.
> This is the same with the new and old themes. OSD seems fine though.
> 4: black artifacts from program guide while watching video. The screen
> does not refresh properly and leaves black bars until you force a refresh
> (move the selector usually). this occured in mythtv 17 and both the myth and
> ivtv devs blamed each other. it was not resolved until myth 18 and now it
> appears to be back.
> I am not ruling out hardware failure even though everything was working as
> well as it ever has before the upgrade... maybe the load from the build
> fried something in ram/cpu.
> Thanks for your help.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20071107/80bdcbdb/attachment.htm 

More information about the mythtv-users mailing list