[mythtv-users] FC6 "lirc dead but subsys locked"

Nick Morrott knowledgejunkie at gmail.com
Sat May 26 17:23:25 UTC 2007

On 26/05/07, Tye Newman <newman_t at sbcglobal.net> wrote:
> Thanks for the suggestions.
> I have done the following:
> Moved all the lirc stuff to the top of modprobe.conf
> Changed the permissions on /etc/udev/lirc.rules so anyone can access it.
> Manually started lirc by entering /sbin/service lircd start
> It returned with OK
> I viewed /dev/li* and found /dev/lircd and /dev/lirc0
> entered irw and things worked great.  Load MythTV work there too.
> Rebooted the system and things stoped working again.
> I have lsmod and it shows lirc_i2c and lirc_dev


> I then tried:
> ADDED: (to rc.local)
> /sbin/rmmod lirc_dev
> /sbin/modprobe lirc_dev

lirc_dev is not the key LIRC module for your device, that is lirc_i2c.
You should normally use 'modprobe -r' instead of rmmod to remove a

> /usr/sbin/lircd --device=/dev/lirc0


> Rebooted, no luck.
> I then REMOVED the above lines.
> Here is a view of my lirc.rules
> KERNEL=="lirc[0-9]*", NAME="lirc%n"
> KERNEL=="lirc0", SYMLINK="lirc"


> I am totally confused.  How can it work, then after reboot stop working.
> I am currently starting lirc manually after reboot (/sbin/service...) and
> testing it with irw.
> Also, how do I modify the $PATH so I don't have to enter /sbin/... for
> commands such as lsmod; and could this be part of the problem.

If you are not logged in as root, /sbin/ will probably not be in your path.


Getting LIRC running well seems to create problems for a lot of users.
On Fedora, I would suggest you do the following (at least, this is
what I do):

i) Create a file called /etc/sysconfig/modules/lirc.modules containing
the following line


This file is read at every boot, and any modprobe commands are run
automatically. It also means that modules are loaded before the
services that depend on them, such as lircd.


If you are using a LIRC module that requires another module loaded
beforehand (like ivtv if using a PVR card with the lirc_i2c module)
you can either create another file called
/etc/sysconfig/modules/ivtv.modules (the name of the file needs to be
alphabetically less than the name of the lirc.modules file) containing
a 'modprobe ivtv' to preload the ivtv module, OR you can update the
/etc/modprobe.conf file to have ivtv automatically loaded whenever the
LIRC module is.

ii) Have the lircd service start at boot - to do this, as root run

# chkconfig --level 345 lircd on

To check it is set to start at boot, run

# chkconfig --list lircd

This will list each run level and whether lircd is set automatically start.

iii) Reboot. You should find that your LIRC modules are automatically
loaded (lirc_dev plus the module for your specific device) and that
you have the /dev/lirc0 device and /dev/lirc symlink created. Starting
the lircd service automatically at boot should also create the
/dev/lircd socket, and at this point irw - and your remote - should

Note that you *do not* have to have the LIRC modules listed first in
/etc/modprobe.conf. Also, when Geoff mentioned altering the
permissions for the LIRC udev rules, he meant altering the rules
themselves, rather than updating the permissions on the actual rules
file itself (I can't tell which of these you did above).


MythTV Official wiki:
MythTV users list archive:

"An investment in knowledge always pays the best interest." - Benjamin Franklin

More information about the mythtv-users mailing list