[mythtv-users] FC6 "lirc dead but subsys locked"

Tye Newman newman_t at sbcglobal.net
Sat May 26 13:02:43 UTC 2007

Thanks for the suggestions.

I have done the following:

Moved all the lirc stuff to the top of modprobe.conf
Changed the permissions on /etc/udev/lirc.rules so anyone can access it.
Manually started lirc by entering /sbin/service lircd start
It returned with OK
I viewed /dev/li* and found /dev/lircd and /dev/lirc0
entered irw and things worked great.  Load MythTV work there too.

Rebooted the system and things stoped working again.

I have lsmod and it shows lirc_i2c and lirc_dev

I then tried:

ADDED: (to rc.local)

/sbin/rmmod lirc_dev 
/sbin/modprobe lirc_dev 
/usr/sbin/lircd --device=/dev/lirc0 

Rebooted, no luck.
I then REMOVED the above lines.

Here is a view of my lirc.rules

KERNEL=="lirc[0-9]*", NAME="lirc%n"
KERNEL=="lirc0", SYMLINK="lirc"

I am totally confused.  How can it work, then after reboot stop working.

I am currently starting lirc manually after reboot (/sbin/service...) and testing it with irw.

Also, how do I modify the $PATH so I don't have to enter /sbin/... for commands such as lsmod; and could this be part of the problem.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070526/6260672d/attachment-0001.htm 

More information about the mythtv-users mailing list