[mythtv-users] Trying to add a Twinhan ATSC (D+A)

Patrick Nichols lists at panic.id.au
Thu May 17 03:33:34 UTC 2007

On 17/05/2007 11:57 AM, Lane wrote:
> The new PCI card is a Twinhan ATSC (D+A), aka TwinhanDTV, and it seems to be 
> recognized on boot, but myth ignores it.  In fact there are no devices 
> created (/dev/v4l..., /dev/video..., etc) during boot.  Yet no errors are 
> reported.
I've found that in order to get my twinhan dvb-t cards working I needed 
to load more modules than just bttv.

The following modules are loaded in /etc/modules:

bttv card=0x71

This is what is reported by dmesg"

[17179591.380000] bttv: driver version 0.9.16 loaded
[17179591.380000] bttv: using 8 buffers with 2080k (520 pages) each for 
[17179591.380000] bttv: Bt8xx card found (0).
[17179591.380000] bttv0: Bt878 (rev 17) at 0000:00:0c.0, irq: 169, 
latency: 32, mmio: 0xdf000000
[17179591.380000] bttv0: detected: Twinhan VisionPlus DVB [card=113], 
PCI subsystem ID is 1822:0001
[17179591.380000] bttv0: using: Twinhan DST + clones [card=113,autodetected]
[17179591.380000] bttv0: gpio: en=00000000, out=00000000 in=00f100fe [init]
[17179591.380000] bttv0: using tuner=4
[17179591.420000] bttv0: add subdevice "dvb0"

[17179591.860000] bt878: AUDIO driver version 0.0.0 loaded
[17179591.860000] bt878: Bt878 AUDIO function found (0).
[17179591.864000] bt878(0): Bt878 (rev 17) at 00:0c.1, irq: 169, 
latency: 32, memory: 0xde800000
[17179591.864000] bt878: Bt878 AUDIO function found (1).

[17179594.152000] DVB: registering new adapter (bttv0).
[17179594.436000] dst_get_device_id: Recognise [DTTDIG]
[17179594.436000] DST type flags : 0x10 firmware version = 2
[17179594.472000] dst_get_mac: MAC Address=[00:08:ca:13:bb:00]
[17179594.472000] DVB: registering frontend 2 (DST DVB-T)...

Hope that helps.

Patrick Nichols

More information about the mythtv-users mailing list