[mythtv-users] Packet dropped due to uncorrectable error.

Brian Wood beww at beww.org
Sat May 12 16:02:22 UTC 2007

Andrew Junev wrote:
> Hello All,
> I'm new to MythTV, trying to set it up on a PIII-1GHz, 512Mb RAM, 60Gb
> HDD system. I have Technotrend S-1401 DVB-S card and I seem to have a
> problem setting it up.
> The system is running Fedora Core 6 with the latest updates. I think I
> have the DVB-S card configured the right way and I have also imported
> channels.conf made by scandvb.
> The problem is when I try to watch a TV I get a message "Error was
> encountered while displaying video". In the frontend logs I see the
> following:
> 2007-05-10 01:24:56.871 TV: Attempting to change from None to WatchingLiveTV
> 2007-05-10 01:24:56.873 Using protocol version 31
> 2007-05-10 01:24:59.253 NVP: Disabling Audio, params(-1,2,44100)
> 2007-05-10 01:24:59.338 VideoOutputXv: XvMCTex: Init failed
> 2007-05-10 01:24:59.340 VideoOutputXv: XVideo Adaptor Name: 'Matrox G-Series Backend Scaler'
> 2007-05-10 01:25:04.031 TV: Changing from None to WatchingLiveTV
> 2007-05-10 01:25:04.158 Realtime priority would require SUID as root.
> 2007-05-10 01:25:04.471 New DB connection, total: 3
> 2007-05-10 01:25:04.474 Connected to database 'mythconverg' at host: localhost
> 2007-05-10 01:25:04.499 Video timing method: DRM
> 2007-05-10 01:26:15.002 RingBuf(/video/10801_20070510012608.mpg): Invalid file (fd -1) when opening
> '/video/10801_20070510012608.mpg'.
> 2007-05-10 01:26:15.002 NVP, Error: JumpToProgram's OpenFile failed.
> 2007-05-10 01:26:15.002 NVP, Error: Unknown error, exiting decoder
> 2007-05-10 01:26:15.003 TV: Attempting to change from WatchingLiveTV to None
> 2007-05-10 01:27:17.614 TV: Changing from WatchingLiveTV to None
> Destroying SipFsm object
> I tried to search on the Net aboout this error and found quite a few
> of similar problems with no common solution. Anyway, I checked the
> ownership and permissions for '/video' directory. Then I tried to put
> it into mythtv-setup with a '/' in the end. Finally, I have also tried
> to change it to '/home/mythtv/store' - all with no success.

<log info deleted>

I certainly don't know much about TV in Russia, but I'm assuming you're
using PAL, and at what I would call "standard definition".

Looks like you are trying to use XvMC, which generally only works with
nVidia-based cards and their drivers.

You seem to be using a Matrox video card of some sort, so the first
thing I'd look at is what video driver you are using.

That CPU would never play back any sort of high-definition without XvMC,
maybe not even then, though it *should* be able to play back standard
def MPEG2, assuming you are not asking it to do too much else at the
time. A PIII 500 or 600 is generally considered the minimum to do SD MPEG2.

Something like KDE would also soak up a lot of resources, I'd use a
mimimalist window manager, if any at all.


What is the format of the video you're getting from your DVB-S card,

What desktop are you using, and with what window manager?

I'd certainly like to help, but there are so many possibilities at this
point that a *lot* more information is required.

Can you get a pre-recorded video file and see if you can play that back?
Can you make and play back a recording? (you said the problem is with
live TV).

More information about the mythtv-users mailing list