[mythtv-users] permisions for /directory

Bill Omer bill.omer at gmail.com
Wed May 9 12:19:25 UTC 2007

On 5/9/07, Damian Surr <damian at gingermagic.co.uk> wrote:
> Hello all,
> I set up a fresh Ubuntu install a couple of weeks ago ready for Myth and
> finally got the time to install myth last night. All went well apart
> from myth not having write access to the directory I've given to it.
> When I set up the partitions, I created a separate partition called
> 'stuff' which Ubuntu mounts quite happily. I'll be putting all my media
> and downloads in here.
> The mythtv section will be:
> /stuff/media/mythtv
> and in the backend setup, I set the recordings location to be
> /stuff/media/mythtv/recordings
> when I finished the setup, I was told that myth couldn't access that
> location.
> I searched the net and found
> sudo chmod -R username /directory
> and ran
> sudo chmod -R myname /stuff
> which gave me the ability to create directorys in /stuff, so I created
> the 'media', 'mythtv' and 'recordings' directorys.
> Myth still couldn't access them, so I tried:
> sudo chmod -R mythtv /stuff
> but is still didn't work. tried:
> sudo chmod -R myname /stuff/media/mythtv
> but still didn't progress. What am I doing wrong?
> Cheers
> Damian

How about sudo chmod a+rx /stuff /stuff/media /stuff/media/mythtv

Also login as mythtv with sudo and try to access the files.  Do a
sudo -i -u mythtv    then see if you can access the files.


More information about the mythtv-users mailing list