[mythtv-users] lirc almost solved

R. G. Newbury newbury at mandamus.org
Tue Mar 27 05:05:54 UTC 2007

Brian Bosch wrote:
> On 3/26/07, Rich West <Rich.West at wesmo.com> wrote:
>> R. G. Newbury wrote:
>>> Brian Bosch wrote:
> For posterity, this in an FC6 system.  I altered modprobe.conf so that
> the following are the first two lines:
> alias char-major-61 lirc_i2c
> install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-install lirc_i2c
> I then took out all changes that made to rc.local & reboot but, alas,
> lircd failed to operate.  I could start it manually but it would crash
> as soon as a client (irw, mythfrontend) tried to connect.
> I left modprobe.conf alone and added back the following two lines to
> rc.local, reboot, and lirc is working fine again:
> /sbin/modprobe lirc_i2c
> /sbin/service lircd start
> (Under your and Geoffrey's suggestion I left out the depmod -a bit.)
> I'm quite happy to leave it running like this, I just wanted to report
> my experience back for the sake of the archives...

It appears to me that you are not loading the actual driver in 
modprobe.conf. The driver module (lirc_imon or whatever) is then 
probably loaded when you call lircd in rc.local. The call to lircd 
probably does 2 things: calls udev and loads the module. When you tried 
before and it crashed, you probably did not yet have a /dev/lirc 
created... at least that's what caused lots of crashes for me when i was 
bashing at lirc.


More information about the mythtv-users mailing list