[mythtv-users] FC5 Diskless boot woes

Rich West Rich.West at wesmo.com
Mon Mar 26 19:09:37 UTC 2007

Don Bossung wrote:
>> -----Original Message-----
>> From: Don Bossung [mailto:donald at bossung.net]
>> Sent: Friday, March 23, 2007 10:34 AM
>> To: 'Discussion about mythtv'
>> Subject: RE: [mythtv-users] FC5 Diskless boot woes
>>> Don Bossung wrote:
>>>> I know that this may not be the appropriate forum for this problem,
>>>> but I am hoping the someone here has had a similar problem as I am
>>>> getting nowhere fast with other lists and google searches.
>>>> Here we go.
>>>> I am using
>>>> FC5 2.6.20 x86_64
>>>> the machine is running
>>>> tftpserver 41-1.2.1
>>>> dhcp 11:3.0.3-28
>>>> system-config-netboot 1.40-1.FC5
>>>> Mythtv 0.20-154
>>>> The above is my backend and I am trying to setup a diskless
>>>> workstation to use as a frontend.
>>>> On the backend I:
>>>> Followed the system-config-netboot docs at
>>>> /usr/share/doc/system-config-netboot-1.40-1 using seciton 2 of this
>>>> document steps 1-6
>>>> For my setup machine I installed vmware server 1.02 on the above box
>>>> and then setup a FC5 vm from cd iso with text install and no
>>>> additional packages. Post install I used yum to update and then group
>>>> install X Desktop Enviroment and KDE (K Desktop Environment) and
>>>> MythtvFrontend.
>>>> After following the docs above I booted the remote machine (Celeron D
>>>> 2.88 1G RAM no drives) The pxe boot and kernel load goes fine until
>>>> the following error occurs:
>>>> RAMDIKSK: Compressed image found at block 0
>>>> EXT2-fs: blocksize too small for device
>>>> attempt to access beyond end of device
>>>> ram0: rw=0, want=18446744056529682440, limit=44184
>>>> isofs_fill_super: bread failed, dev=ram0, iso_blknum=17,
>>> block=2147483648
>>>> No filesystem could mount root, tried: ext2 iso9660
>>>> Kernel panic - not synching: VFS: Unable to mount root fs on
>>>> unknown-block(1,0)
>>>> I don't get why so many blocks (18 pentillion???) are being requested.
>>>> I don't think dhcp/tftp is the culprit as I am getting the kernel.
>>>> Could it be that I used vmware as the base for creating the base image
>>>> used by netboot on the remote machine?
>>>> BTW, I used the vmlinuz and initrd.img from the Fedora Core 5 dvd and
>>>> was able to load that with no problem using the same setup.
>>>> Again, I know I am way off topic here, but if you have any ideas, let
>>>> me know.
>>> I'll be the one to follow this up with a "me too" type of post, which
>>> many on the list despise.  However, I think it is worth stating that you
>>> are not alone in the scenario.
>>> I noticed the same problem and fought with it for a couple of nights,
>>> playing with the "ramdisk_size=" and "ramdisk_blocksize=" kernel
>>> arguments within the PXE config to adjust things.  I got past that
>>> particular error with :
>>>     append  initrd=MythTV4/initrd.img root=/dev/ram0 init=/disklessrc
>>> NFSROOT= ramdisk_size=21912
>>> ETHERNET=eth0 SNAPSHOT=mythtv4  ramdisk_blocksize=1024 ip=dhcp
>>> While that got me past the error, I hit another show-stopper error a
>>> couple of lines further down (where it is supposed to mount the
>>> filesystems and execute /disklessrc and S01diskless), and that is where
>>> I tossed in the towel.  I figured I would work on upgrading all of the
>>> systems to FC6 and address the diskless setup again.
>> Thanks, it is good to see I am not the only one (wow did that come out
>> wrong!) Did try the ramdisk size/blocksize with no luck. I think I will
>> try the FC6 fixes listed in the diskless frontend howto and give it
>> another go.
> Thought I would update this with the solution I found. The first time I
> built the setup machine in vmware, I used the default of LVM for swap/root.
> I rebuilt the setup machine and re-rsynched everything and got to the login
> prompt. I did add the ramdisk_blocksize=1024 as per the Diskless Frontend
> howto in the wiki. When I tried to login, I got a message that flashed on
> the screen then the login prompt would reappear. This happened regardless of
> the user I tried to login as. Using Ctrl-S I was able to freeze the screen
> and saw that is was an SELinux audit error message. I thought this was odd
> as I had turned off SELinux on the setup machine before rsynching. So, I
> went back to the pxe default config file and added selinux=0 to the append
> line. All is good now and I can login to the diskless workstation.

Wow!  Great to hear!  If you get a moment, can you update the Wiki to
fill in any parts of the process that you went through that were either
unclear or completely missing in the wiki entry?  This would be very


More information about the mythtv-users mailing list