[mythtv-users] XvMC not working - Nvidia

Yan Seiner yan at seiner.com
Fri Mar 23 22:45:13 UTC 2007

Damian Surr wrote:
> Just tried that and restarted gdm. Still get about 10 fps with 
> glxgears! The kind of numbers I see on the net are in their thousands. 
> Do you think there's something wrong with my card? Those numbers seem 
> too big to bridge with a settings tweak or something.
> It's a bit late to find this out if it is hardware. I bought the card 
> about 3 months ago, just not known how to test it.

It ain't the card.

It's something in your config.

type 'glxinfo | grep NV'

You should see three lines with NVIDIA.  (I'm going from memory so the 
case could be different....)  It is possible you still have mesa libs 
from X11 kicking around.

If you don't see three lines and in particular if you see a line with 
SGI, then reinstall the nvidia drivers.

I think glxinfo also tells you if dri is enabled; it is in the top 10 
lines or so.  If you see something about 'dri  no' then your nvidia 
install is hosed.  Again, reinstall the nvidia drivers.

I don't know your hardware config; if you have more than one monitor 
connected to your card, only the first one will have hardware 
acceleration.  Make sure you have only one monitor connected and 
configured in xorg.conf.

It wouldn't be a bad idea to let nvidia set up your xorg.conf.  Make a 
backup first; I typically lose my mouse if I let nvidia run its config.

Lastly, /var/log/Xorg.0.log makes for boring but rewarding reading.  
You're looking for the parts where it tries to initialize dri and / or 
glx, but in general anything that indicates that nvidia couldn't get 
acceleration going.


More information about the mythtv-users mailing list