[mythtv-users] The remote control from outer space

Angus sylvania at istop.com
Mon Mar 19 23:17:56 UTC 2007

I've been trying to get this remote to work with lirc for a week now, 
with little success. I'm wondering if there's something unusual about 
its type that hasn't been considered, like it's not GPIO or something.
    If I try using irrecord, it can't find the "gap". The remote is 
being detected, because I can see periods being sent to the screen with 
every push of the button. I've also tried looking at xev's output, but 
its output is the same with every button I push. I've even tried adding 
support for the card myself, by following the instructions at 
http://www.linuxtv.org/v4lwiki/index.php/Remote_controllers. The results 
from those tests also indicate that each button on the remote is read 
the same. When I look in /var/log/messages I see two build_key messages 
with each button push: one has gpio=0x40 and another is gpio=0x0, no 
matter which button I push.
    Do I need lirc for MythTV to work? Is it an essential tool? There's 
no model number on the remote whatsoever, but the card it came with is a 
KWorld Global Terminator, which is *supposed* to be supported, according 
to the documentation I've read.

More information about the mythtv-users mailing list