[mythtv-users] No /dev/dvb devices

Lachlan McIntosh lachlan at directions.com.au
Sun Mar 18 21:30:04 UTC 2007

>From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of David Highley
>Sent: Monday, 19 March 2007 6:47 AM
>To: mythtv-users at mythtv.org
>Subject: Re: [mythtv-users] No /dev/dvb devices

"Michael T. Dean wrote:"
> On 03/18/2007 02:17 PM, Yeechang Lee wrote:
> > Anthony Messina <amessina at messinet.com> says:
> >   
> >> i have the same issue as the previous poster.  since it worked for
> >> you, would you mind sharing your /etc/modprobe.conf?
> >>     
> >
> > I don't have any HD5000-related entries in my /etc/modprobe.conf.
> >
> >   
> OP just needs to load cx88-dvb through his distro's supplied automatic

> module-loading scripts (i.e. /etc/modules or /etc/sysconfig/modules or

> /etc/modprobe/cx88-dvb or ... --ask on your distro's fora/mailing
> or through an appropriate modprobe.conf entry (the first is easier
> the second approach).  Note, also, that Linux 2.6.21 will likely fix
> issue causing cx88-dvb to fail to load automatically, so doing things 
> incorrectly (i.e. through auto-module-loading scripts) for such a
> time is not a big deal.

>That fixed it. I put a "modprobe cx88-dvb" line in the rc.local file as
>a temporary work around. I had tried modprobing other drivers, just
>could not remember which one I needed. Thanks

I had a similar issue after upgrading to 2.6.20 (debian) to make my new
Gigabyte 965P-DS3P PC work 
with a Nova-T card. Previously under 2.6.17 it just "worked", however
now I need to do (all seemed to be necessary to get the firmware to load
and order seemed to be important):

        modprobe saa7146
        modprobe saa7146_vv
        modprobe ttpci-eeprom
        modprobe budget-core
        modprobe budget
        modprobe budget-ci
        modprobe tda1004x
        modprobe mxb
        chown -hR root:video dvb
        chmod -R 777 /dev/dvb

Hopefully this will save someone else a few hours of pulling their hair
out after midnight.

Now if I could just convince ALSA to recognise that the onboard sound
actually has a mixer.....

Lachlan :o)

More information about the mythtv-users mailing list