[mythtv-users] Problem with lirc install

gwgrover at windstream.net gwgrover at windstream.net
Fri Mar 16 16:15:34 UTC 2007

Message: 6
Date: Thu, 15 Mar 2007 23:16:11 +0200
From: Jaakko Heikkilä <jaakko.heikkila at gmail.com>
Subject: Re: [mythtv-users] Problem with lirc install
To: Discussion about mythtv <mythtv-users at mythtv.org>
Message-ID: <1173993371.4318.23.camel at home.varpula.org>
Content-Type: text/plain
> I tried yast-2; it told me lirc was already installed; yet I could not 
> find any hint of any lirc mods - no kernel mods, no daemons, nothing - 
> Did a lot of google searching and a lot of reading; and elected 
> to follow the least confusing howto. 

Few things to check if you want to use lirc installed by yast.

/etc/sysconfig/lirc is the file you have to edit to make lirc work. Here
are the settings I had to edit to make lirc work:

So, lirc module is loaded by lirc init script. Right module depends on
your hardware. When module is loaded you can
check /proc/bus/input/devices to find right input device for you.

Is lirc really loaded? You can use "yast2 runlevel" command to lounch
GUI tool or use command line tools. Run "rclirc status" to check if lirc
is running, "rclirc start" to load lirc and chkconfig --add lirc to make
lirc load at boot time.

> I ran a yast upgrade and it upgraded the kernel; now lirc-0.8.0 
> does not work; lirc-0.8.1 is needed. 

I haven't upgraded kernel for a while. Maybe I'll check if that breaks
anything for me.

> All I want to do is make it so that when mythtv changes channel
> to record a program, it also lites up an irblaster to make the satelite 
> box change to the proper channel. (dish network)
When I try to use "yast2 runlevel" to start lirc, the responce was that 
lirc was not configured and I can not find a folder containing the lirc ./configure 

More information about the mythtv-users mailing list