[mythtv-users] Mythfilldatabase segmentation fault

Christopher Friend christopher_friend at hotmail.com
Thu Mar 15 15:20:02 UTC 2007

Hi, I'm getting the following segmentation fault error at the end of each 
mythfilldatabase run. Looks like this...

removing existing program: yorkshire.granadatv.co.uk Along Came Polly 
2007-03-21T23:00:00 - 2007-03-21T23:20:00
inserting new program    : yorkshire.granadatv.co.uk Along Came Polly Wed 
Mar 21 23:00:00 2007 - Wed Mar 21 23:20:00 2007

Updated programs: 407  Unchanged programs: 11237
2007-03-15 15:12:55.492 Data fetching complete.
2007-03-15 15:12:55.492 Adjusting program database end times.
2007-03-15 15:12:55.755     0 replacements made
2007-03-15 15:12:55.755 Marking generic episodes.
2007-03-15 15:12:55.901     Found 1
2007-03-15 15:12:55.902 Marking repeats.
2007-03-15 15:12:56.031     Found 0
2007-03-15 15:12:56.031 Unmarking new episode rebroadcast repeats.
2007-03-15 15:12:56.158     Found 0
2007-03-15 15:12:56.439 Marking episode first showings.
2007-03-15 15:13:02.061     Found 7577
2007-03-15 15:13:02.061 Marking episode last showings.
2007-03-15 15:13:06.645     Found 7577
2007-03-15 15:13:06.703
| Attempting to contact the master backend for rescheduling.  |
| If the master is not running, rescheduling will happen when |
| the master backend is restarted.                            |
2007-03-15 15:13:06.706 Connecting to backend server: (try 1 
of 5)
2007-03-15 15:13:06.707 Using protocol version 31
2007-03-15 15:13:08.369 mythfilldatabase run complete.
Segmentation fault

Basically it all looks fine appart from the final line. That it it seems to 
update a lot less programs entries that it usually does, though it's got a 
lot of data from previous runs so that may be normal.

I've tried mythfilldatabase --refresh-all but it did nothing, and i'm not 
sure it works with the uk radiotimes grabber anyway.

I also have this error in mythweb...

"mythfilldatabase ran, but did not insert any new data into the Guide. This 
can indicate a potential grabber failure."

And a few days earlier it came up with this, which may be unconnected as i'm 
pretty sure mythfilldatabase ran fine when i first saw this:

"There's guide data until 2024-07-11 05:08 (6328 days)."

Any ideas what may be up? Or how i can repair/replace the table containing 
program data?

I'm running 0.20-19 on suse 10.2, xmltv with the uk_rt grabber, and 
I'm pretty sure the error occured at a time when the system was the same as 
it was when it worked previously.

Only other possible cause I can think of is an overclocked processor. It 
feels perfectly fine, has been clocked higher previously without problem, 
but i have noticed a couple crashes of a single mod of a single game in 
windows which may be processor related, and i've had previous experience of 
processors causing seg faults, but i'm pretty sure it's not that.


The Crimea / The Crocketts

MSN Hotmail is evolving - check out the new Windows Live Mail 

More information about the mythtv-users mailing list