[mythtv-users] compilation problems on Mac mini PPC useing osx-packager.pl

hary wilke harywilke at yahoo.com
Sun Mar 4 18:09:36 UTC 2007

i've got a mac mini PPC that i'm trying to compile the mythfrontend from the osx-packager.pl script but i've run into a snag. 
I'm getting the following error when running the command:        

./osx-packager.pl -verbose -pluginskip -themeskip

cd libavcodec && qmake libavcodec.pro "PREFIX=../Resources" "QMAKE_LFLAGS+=-Wl,-search_paths_first" "INCLUDEPATH+=/usr/local/src/mythtv/.osx-packager/build/include" "LIBS+=-L/usr/lib -L/usr/local/src/mythtv/.osx-packager/build/lib" -o Makefile
cd libavcodec && /usr/bin/make -f Makefile
cc -c -pipe -mcpu=7450 -mtune=7450 -mpowerpc-gfxopt -faltivec -w -O3 -I/usr/local/src/mythtv/.osx-packager/build/include -no-cpp-precomp -pipe -force_cpusubtype_ALL -Wno-sign-compare -fomit-frame-pointer -Wall -Wno-switch -fomit-frame-pointer -faltivec -DPIC -fPIC  -DMMX -Di386 -DUSING_APPLEREMOTE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr/local/src/mythtv/.osx-packager/build\" -DLIBDIR=\"/usr/local/src/mythtv/.osx-packager/build/lib\" -DHAVE_AV_CONFIG_H -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_ACCESSIBILITY_SUPPORT -I/usr/local/src/mythtv/.osx-packager/src/qt-mac-free-3.3.6/mkspecs/default -I. -I.. -I../.. -I../libavutil -I/usr/local/src/mythtv/.osx-packager/src/qt-mac-free-3.3.6/include -o bitstream.o bitstream.c
cc -c -pipe -mcpu=7450 -mtune=7450 -mpowerpc-gfxopt -faltivec -w -O3 -I/usr/local/src/mythtv/.osx-packager/build/include -no-cpp-precomp -pipe -force_cpusubtype_ALL -Wno-sign-compare -fomit-frame-pointer -Wall -Wno-switch -fomit-frame-pointer -faltivec -DPIC -fPIC  -DMMX -Di386 -DUSING_APPLEREMOTE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr/local/src/mythtv/.osx-packager/build\" -DLIBDIR=\"/usr/local/src/mythtv/.osx-packager/build/lib\" -DHAVE_AV_CONFIG_H -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_ACCESSIBILITY_SUPPORT -I/usr/local/src/mythtv/.osx-packager/src/qt-mac-free-3.3.6/mkspecs/default -I. -I.. -I../.. -I../libavutil -I/usr/local/src/mythtv/.osx-packager/src/qt-mac-free-3.3.6/include -o utils.o utils.c
{standard input}:7813:Invalid mnemonic 'emms'
{standard input}:7895:Invalid mnemonic 'emms'
make[2]: *** [utils.o] Error 1
make[1]: *** [sub-libavcodec] Error 2
make: *** [sub-libs] Error 2
[osx-pkg] Failed system call: " /usr/bin/make  " with error code 2
Died at ./osx-packager.pl line 906.

has anyone seen this before?
I tried switching to gcc 3.3 from 4.0 and rebuilding everything, but i got the same error. 
i'm not a programmer by any stretch of the imagination, so the gcc switch was a blind stab in the dark.

thanks for any help


More information about the mythtv-users mailing list