[mythtv-users] mythtv-setup -> Capture card -> sound device = none

Ari Børde Krøyer ari.kroyer at c2i.net
Sat Mar 3 08:51:27 UTC 2007

I had a working installation of Mythtv and decided to rebuild it with 
LVM so I can extend my /var/video with the addition of a new disk later.

Anyway, now the setup program reports "none" for the sound device of my 
capture card, and manually entering it does not help. I would guess the 
problem is not in mythtv itself, but I am at a loss right now.


Motherboard:   Gigabyte GA 6CXC7
Framegrabber:   Pinnacle PCTV Stereo (SAA7134, card 26)
Sound:   Ensonic ENS1371 (Not using the onboard sound)

The apropriate drivers are compiled as modules and dmesg reports the 
cards on boot. However I am not sure about the sound from the 
framegrabber card. I previously used the SAA7134-alsa module to get DMA 
sound. This worked, although I only got one channel (right). Now it does 
not work any more, and I can't find the fault.

I had to spend some time setting up sound last time too. First I tried 
using a jack from the TV-card to the sound card, but no result. I read 
somewhere that the SAA7134 is muted by default. Editing the source and 
recompiling didn't help. I then opted for SAA7134-alsa. No result. 
Finally I discovered that this card was loaded as the primary sound card 
(cat /proc/asound/cards) I fixed that and I got sound.

Howerer, after the fresh install, that no longer solves it...

Please help!


More information about the mythtv-users mailing list