[mythtv-users] Fedora 7 problem

David George david at thegeorges.us
Tue Jul 31 00:12:15 UTC 2007

On 07/30/2007 07:25 PM, John Pierce wrote:
> Hi all!
> I just did away with my opensuse 10.2 box in favor of fedora 7 x86_64.
>  I went through the standard install and then setup from the atrpms
> repo, I have setup the mysql database from a dump of the previous
> database.  I do a restore with mysql -p -u root < mythbackend.bak and
> when I check there is the database restored with all 74 tables and
> they are populated with data (well not all of them have data just
> some) and if I start mythbackend --daemon from a command line this is
> what I get:
> QSqlDatabase: available drivers:
> 2007-07-30 18:15:26.256 New DB connection, total: 1
> 2007-07-30 18:15:26.256 Unable to connect to database!
> 2007-07-30 18:15:26.256 No error type from QSqlError?  Strange...
> QSqlQuery::exec: database not open
> QSqlQuery::exec: database not open
> 2007-07-30 18:15:26.310 DB Error (KickDatabase):
> Query was:
> No error type from QSqlError?  Strange...
> 2007-07-30 18:15:26.363 Failed to init MythContext, exiting.
> I have no clue how to fix this, I have googled and read for the last
> several hours and I still have not come up with anything.
> Any suggestions, thoughts, ideas would be greatly appreciated.

Is this the missing qt-mysql problem?  Try 'rpm -qa | grep -i qt-mysql' 
and see if you have it installed.  If this doesn't return the package do 
a 'yum install qt-MySQL' (at least this is what it is on Fedora Core 6).


More information about the mythtv-users mailing list