[mythtv-users] Mythfrontend and 480i modes

Steven Adeff adeffs.mythtv at gmail.com
Wed Jan 31 14:55:28 UTC 2007

On 1/31/07, Calvin Harrigan <charriglists at bellsouth.net> wrote:
> Steven Adeff wrote:
> > On 1/29/07, Calvin Harrigan <charriglists at bellsouth.net> wrote:
> >> As reported earlier, I've successfully set up HDTV on my myth system.
> >> One of the issues I faced was not being able to select de-interlacing
> >> per video mode. So I decided to create modes per resolution.  I am able
> >> to select a 1080i mode to view 1080i content,etc.  I'm having a problem
> >> playing back 480i.  Thought I have a  good mode line mythtv/X11
> >> interprets the mode as 720 x 240  (480/2 for interlaced I guess) so myth
> >> scales the video horizontally to match the vertical resolution. So I
> >> have a tall narrow picture on the screen.  I'm not convinced it's an
> >> actual mythtv problem though.  I'm thinking it might be a X11 and/or
> >> nvidia driver issue.  Looking in the X logs using the '-logverbose 6'
> >> switch I see where the driver seems to be setting a 480i mode, but X
> >> reports it as 720x240.
> >>
> >> The TV indicates it's displaying 480i mode and the raster seems to be
> >> the size I expect it to be.
> >>
> >> Has anyone seen a similar issue?  Any workarounds?
> >
> > what is your 480i modeline? its possible your giving it a 720x240
> > modeline instead of the 720x480_60i modeline you think your giving it?
> >
> > As for the deinterlacing per video mode, any reason you need to do this?
> >
> My 480i mode is from the modepool as reported in the X logs.
> "720x480"  interlaced
> "720x480_60" Non interlaced
> there is also a "720x480_120i" and a "1440x480" (interlaced)mode.  Tried
> both, seem to be aliases for other modes.
> Unfortunately xrandr doesn't pick them up as seperate resolutions, it
> picks the one that's listed first in the screens section of the
> xorg.conf.  Mythtv doesn't pick them up as seperate resolutions either,
> myth is probably using the same X calls to retrieve the defined modes.
> Wish there was some way to list all the modes in the mode pool in
> xrandr/mythtv.
> I would only need to deinterlace if I can't get the 480i mode working.
> In that case I would have to deinterlace the 480i pvr250 recording to
> playback at 720p or even 480p.  What's odd is that the gui is drawn
> properly in the 480i mode.  But neither mythtv or mplayer plays back the
> 480i recording properly.  There are some blocking artifacts, not like
> mpeg artifact.  For example diagonal lines are quite jagged on screen
> text edges are rough, etc.  I think there might be some sort of mismatch
> in either interlacing order, refresh rate, or resolution.  The fact the
> 1080i works beautifully leads me to thing it might also be a software
> issue.  My next experiment to record a digital 480i signal and see how
> that plays back as opposed to the pvr250 480i recording.

I find it odd that its returning 720x240 for a ModePool 720x480 mode.
You say the menu works properly, so try playing with the playback
aspect ratio in Myth("w" key). Also look to see what your DisplaySize
settings in your xorg.conf are.

Before you ask, read the FAQ!
then search the Wiki, and this list,
Mailinglist etiquette -

More information about the mythtv-users mailing list