[mythtv-users] HD Woes (getting closer)

Nate Crosno nate at crosno.net
Tue Jan 30 15:38:16 UTC 2007

Nate Crosno wrote:
> Steven Adeff wrote:
>> try replacing your EDID and ModeTimings options with the
>> ModeValidation equivalents (or getting rid of them entirely).
> Alrighty, we are making a little progress here.  Still working with DVI 
> and not component (the onboard NV 6100 has both).  After removing the 
> EDID stuff and restarting X in verbose mode, I saw a bunch more possible 
> modes.  No 1920x1080_60 modes though....
> (II) NVIDIA(0): "1920x1080"          : 1920 x 1080 @ 120.1 Hz Interlace  
> (from: EDID)
> (II) NVIDIA(0): "1920x1080_120i"     : 1920 x 1080 @ 120.1 Hz Interlace  
> (from: EDID)
> (II) NVIDIA(0): "1440x480"           : 1440 x  480 @ 120.1 Hz Interlace  
> (from: EDID)
> (II) NVIDIA(0): "1440x480_120i"      : 1440 x  480 @ 120.1 Hz Interlace  
> (from: EDID)
> (II) NVIDIA(0): "1280x720"           : 1280 x  720 @  60.0 Hz  (from: EDID)
> (II) NVIDIA(0): "1280x720_60"        : 1280 x  720 @  60.0 Hz  (from: EDID)
> .....and downward....
> There is no 1920x540 mode either.  When I try the first 1080i mode 
> above, the screen is twice as tall as it should be (can't see the bottom 
> half). Seems like I really need a 540 tall desktop.I tried putting in 
> "1920x540" as a mode, but it rejected that.  Maybe my EDID is reporting 
> junk?

Still closer...

I tried the 540i setting reported my my EDID again.  I had tried it before, but X rejected it. Now that the EDID options in xorg.conf are different, it took it.  However, now the problem is nearly the opposite of what I reported above: the width is twice is big as it should be and is squished to fit the screen.  Here is the mode generated by the EDID export from nvidia-settings:

        Mode    "1920x540"      # vfreq 60.053Hz, hfreq 33.750kHz
                DotClock        74.250000
                HTimings        1920 2008 2052 2200
                VTimings        540 542 547 562
                Flags   "Interlace" "+HSync" "+VSync"

I also tried the 960x540p mode from Jarod Wilson's guide (also notice it on other non-myth sites):

        Mode "960x540p"
                DotClock 37.26
                HTimings 960 976 1008 1104
                VTimings 540 542 548 563
                Flags "+HSync" "+VSync"

X took it without complaining, and the proportions were correct on the display, but it still required deinterlacing for 1080i content in Myth and my cpu usage was still maxed out (running latest .20 ebuild, BTW). X also took his "in1080i" mode, but my TV would not (blank screen).

The 540p mode did seem to pause less often then other things I have tried. Which deinterlacer would be best for this mode?

Is there such a thing as a 960x540i mode? I tried some modeline calculators but could not come up with anything that X would take.  That mode does not make sense to me, but from the tests above, it seems like that is what the TV is wanting. ???


More information about the mythtv-users mailing list