[mythtv-users] Myth gui offset problem

Calvin Harrigan charriglists at bellsouth.net
Thu Jan 25 20:04:50 UTC 2007

|  X background                 |
|                               |
|    ---------------------------|
|    |                          |  720
|    |         Myth GUI         |
|    |                          |
|    |                          |

I'm having a bit of a problem with the mythfrontend gui and ratpoison.
I think ratpoison might be part of the problem because without it the 
GUI is drawn properly, but I had focus issues.

My xorg.conf has a 1080i modeline in it, mythtfrontend starts up and 
seems to scale fonts, themes, etc to that resolution (the max 
resolution). Myth almost immediately switches to 1280x720p because of 
the mode I have set for the gui to run in under the setup->appearance 
menu. (seperate modes per video resolution and gui).  The diagram above 
shows what I am experiencing.  Myth and/or ratpoison is drawing the gui 
on what seems to be centered on a virtual 1920 x 1080 screen.  I've 
tried adjusting the offset for gui position in the setup but that 
doesn't seem to have any effect.  It's as myth it's ignoring the 
setting.  The offsets do work if I remove the 1080 mode though.  I could 
then position the screen where I want on the screen.

Is there a way to convince mythtv to scale to a preset mode (1280x720p 
in this case) other than the mode it's started in?  Is this a bug in 
ratpoison?  Anyone else experience a similar problem?  Searched the list 
and found one reference to something similar.  It was suggested that the 
person use xrandr to set the resolution to what was needed before 
starting mythfrontend.  That doesn't seem to work for me either.


More information about the mythtv-users mailing list